Closed Bug 865809 Opened 8 years ago Closed 8 years ago

Click-to-play (hidden pref) does not work in Nightly

Categories

(Core :: Plug-ins, defect)

23 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: alice0775, Unassigned)

References

()

Details

(Keywords: regression)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/690b5e0f6562
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130425 Firefox/23.0 ID:20130425030845

Steps to Reproduce:
1. set plugins.click_to_play to true and restart browser
2. Open http://www.youtube.com/watch?v=55s3T7VRQSc

Actual Results:
Flash Player start 

Expected Results:
Flash Player should be blocked.
And Click-to-play Icon should appear.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/07e17dd7813b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130424 Firefox/23.0 ID:20130424131851
Bad:
http://hg.mozilla.org/mozilla-central/rev/690b5e0f6562
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130424 Firefox/23.0 ID:20130424184951
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=07e17dd7813b&tochange=690b5e0f6562

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a4fc2d70eade
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130424 Firefox/23.0 ID:20130424091750
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/450bbfd48532
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130424 Firefox/23.0 ID:20130424092150
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a4fc2d70eade&tochange=450bbfd48532

Regressed by:
450bbfd48532	David Keeler — bug 549697 - add click-to-play plugin UI to the addon manager r=unfocused r=jaws
Did you enable the click-to-play UI in the addon manager?
Bug 549697 is the "culprit" here. Click to play still works, but you need to set the plugins to "Always ask".

Any plans to set "Always ask" as the default option?
I think that would be preferable.
Yes, but we need to do some additional work first.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Ok, thanks!
Summary: Click-to-play does not work in Nightly → Click-to-play (hidden pref) does not work in Nightly
Duplicate of this bug: 865866
Duplicate of this bug: 866509
Duplicate of this bug: 866782
Which bug will take care of that, Bug 775857? Maybe we should remove the plugins.click_to_play pref from browser/app/profile/firefox.js as long as the pref does not do anything. Because right now you can switch the pref and then notice that nothing happens (and assume that this is a bug).
(that comment was in reply to Comment 3)
Ok, responding to myself... Bug 866935 wants to remove the pref, Bug 866390 wants to add a new pref that basically ends up doing the same as the current plugins.click_to_play pref.
For posterity, I just wontfixed bug 866935. Bug 866390 will re-purpose the old pref to do... exactly what it used to do.
Duplicate of this bug: 876136
(In reply to annaeus from comment #2)
> Bug 549697 is the "culprit" here. Click to play still works, but you need to
> set the plugins to "Always ask".
> 
> Any plans to set "Always ask" as the default option?
> I think that would be preferable.

With that thing it kinda works, but can't remember anymore the options you set for a website i.e. situation with DropBox when I set "Always activate plugins for this site" it doesn't set anything. It reports as if the option is set but each time I reload the page it asks me again. 

Anyway what was the real problem with the old functionality that someone decided to destroy it  ?
Ah just found out it only happens with DropBox, though setting through Page Info seems to do the trick.
(In reply to Žilvinas from comment #14)
> Ah just found out it only happens with DropBox, though setting through Page
> Info seems to do the trick.
Thanks Zilvinas. Filed bug 876362 for this.
Duplicate of this bug: 875590
Duplicate of this bug: 888220
Duplicate of this bug: 889240
Duplicate of this bug: 901949
Duplicate of this bug: 902106
Duplicate of this bug: 902405
Duplicate of this bug: 902376
Duplicate of this bug: 902751
Duplicate of this bug: 903596
Duplicate of this bug: 906441
For anyone else trying to figure this out.  To turn on click to play, you must go to:
about:addons > plugins > select 'Ask to activate'
You need to log in before you can comment on or make changes to this bug.