for images that get layerized Draw is never called on them, but rather GetImageContainer so they don't get marked as visible

RESOLVED FIXED in Firefox 22

Status

()

Core
ImageLib
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: tnikkel, Assigned: tnikkel)

Tracking

Trunk
mozilla23
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox22 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 742218 [details] [diff] [review]
patch

So we should send the same OnUnlockedDraw notification from GetImageContainer if the image is not locked.
Attachment #742218 - Flags: review?(joe)
Attachment #742218 - Flags: review?(joe) → review+
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6255ed636db1
(Assignee)

Comment 2

5 years ago
Comment on attachment 742218 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 689623
User impact if declined: dynamically added images that get their own layers (meeting some conditions including having opacity or an active transform) won't animate
Testing completed (on m-c, etc.): just landed on inbound now
Risk to taking this patch (and alternatives if risky): this is a relatively safe patch, I think the risk of not taking it is higher than the risk of taking it
String or IDL/UUID changes made by this patch: none
Attachment #742218 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/6255ed636db1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23

Comment 4

5 years ago
Comment on attachment 742218 [details] [diff] [review]
patch

Early enough in the cycle to take a fix for what is yet to be deemed a critical release issue.
Attachment #742218 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/795edee27c88
status-firefox22: --- → fixed
You need to log in before you can comment on or make changes to this bug.