Persona login with available https siteLogo not working if request is from http page

RESOLVED INVALID

Status

()

Core
Identity
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: olav, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1488.0 Safari/537.36

Steps to reproduce:

1. Included login.persona.org/include.js shim

2. Entered navigator.id.request({siteLogo: '/img/logo.png'}); from a site on normal http, when the logo was available both on http and https.


Actual results:

Error saying: improper usage of API: Error: only https sites can specify a siteLogo


Expected results:

Should have tried retrieving the https logo.
Hi, Olav,

We track persona issues in github.  Let's take the discussion here:

https://github.com/mozilla/browserid/issues/3314

Thanks,
j
Closing since the bug has moved over to github.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.