Developers should be able to directly install their own paid apps.

RESOLVED FIXED in 2013-05-02

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: vcarciu, Assigned: andy+bugzilla)

Tracking

2013-05-02
x86_64
Gonk (Firefox OS)
Points:
---

Details

(Whiteboard: p=2)

(Reporter)

Description

5 years ago
Prerequisites:
User have some paid apps already submitted

Steps to reproduce:
1.Login to MP app 
2.Search for an owned paid app
3.Press the Install buton

Expected results:
The app should be directly installed

Actual results:
Purchase process is started
This already works, you can see bug 855912 for details. You have to be logged in with the exact developer account you used to uploaded the app with.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855912
(Reporter)

Comment 2

5 years ago
I am logged with this account.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

5 years ago
Blocks: 775802
Can you tell me the name of the app and the exact email address you used when submitting the app?
(Reporter)

Comment 4

5 years ago
(In reply to Kumar McMillan [:kumar] from comment #3)
> Can you tell me the name of the app and the exact email address you used
> when submitting the app?

I used carcium@gmail.com and you can try with "Test App(test21)"
I witnessed this on Victor's unagi phone; the button said "install" but when you click it, the purchase flow starts.
Assignee: nobody → amckay
Priority: -- → P1
(Assignee)

Updated

5 years ago
Whiteboard: p=2
Target Milestone: --- → 2013-05-02
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/zamboni/commit/8c6148
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
The purchase payment flow is still opened if the developer try to Install his own app
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

5 years ago
I cannot reproduce on -dev (although I do see other issues).

http://screencast.com/t/QF848j3XFBJb
(Reporter)

Comment 10

5 years ago
(In reply to Kumar McMillan [:kumar] from comment #9)
> Victor, can you try it on dev? https://marketplace-dev.allizom.org/

Yes, I am not able to reproduce on -dev.
Thanks. Each night, the changes will be available on stage and every Thursday they will be available in production
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.