google webgl maps crash in mozilla::WebGLContext::TexImage2D_base while dragging route

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Ionel Maries, Unassigned)

Tracking

({crash})

21 Branch
x86
Windows 8
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130423212553

Steps to reproduce:

Enable webgl in google maps.

Play with routes (drag em around), eg: open http://goo.gl/maps/XBBMw hold route, keep dragging - it should crash in few seconds



Actual results:

Firefox crash. Details: https://crash-stats.mozilla.com/report/index/bp-6ecd4e4a-1425-45d2-b703-106142130426


Expected results:

Not crash

Comment 1

5 years ago
Firefox 21 and Nightly don't crash for me on Google MapsGL while dragging the route.
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Severity: normal → critical
Flags: needinfo?(ionel.mc)
Keywords: crash
Hardware: x86_64 → x86
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

It works for me on Windows 7 x64, I'm testing Firefox 21.0b5 ([testday-20130426])
(In reply to Maria Grazia Alastra [:mga] from comment #2)
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
> 
> It works for me on Windows 7 x64, I'm testing Firefox 21.0b5
> ([testday-20130426])

Sorry, didn't see the bug was on Windows 8!

Comment 4

5 years ago
Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130429 Firefox/23.0

I was not able to reproduce this issue on Firefox latest nightly (Build ID:	20130429030926).
You can try with a clean profile. 
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Updated

5 years ago
Summary: google webgl maps crashes browser while dragging route → [@ je_malloc | arena_run_dalloc | arena_run_dalloc | je_free | EnterIon ] google webgl maps crashes browser while dragging route

Updated

5 years ago
Crash Signature: [@ je_malloc | arena_run_dalloc | arena_run_dalloc | je_free | EnterIon ]
Could this be another manifestation of bug 793126?

Comment 6

5 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #5)
> Could this be another manifestation of bug 793126?
No, it's a JS crash likely caused by an extension.
(Reporter)

Comment 7

5 years ago
Can't reproduce it in safe mode, but it is extremely slow. It's so slow it's unusable (videocard is 560ti and cpu is i7@4.4ghz). Maybe video acceleration is disabled in safe mode - what settings control this?
Flags: needinfo?(ionel.mc)

Comment 8

5 years ago
Safe Mode disables HW acceleration. You should find the faulty extension by following steps in: https://support.mozilla.org/kb/troubleshoot-extensions-themes-to-fix-problems
Component: Untriaged → Extension Compatibility
(Reporter)

Comment 9

5 years ago
I've created a brand new profile with no extensions - still crashes. 

Please make sure the google maps webgl experiment is active before you try to reproduce it - it can get disabled for no reason. 

Just scroll down the directions list to see if it active. If you don't see "MapsGL enabled" then you're not testing this properly.

Comment 10

5 years ago
I tried again, checked the MapsGL enabled at the bottom and still no crash in Nightly.

Are you sure it's the right crash ID in comment 0?
Provide also the Graphics section of about:support.
Flags: needinfo?(ionel.mc)
(Reporter)

Comment 11

5 years ago
What about firefox 21.0 (the beta) ?

Here's the latest crash: https://crash-stats.mozilla.com/report/index/bp-e020bdc6-6a41-4e28-9d34-2278a2130510
And support info:


  Application Basics

        Name
        Firefox

        Version
        21.0

        User Agent
        Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Feedback
        1.2.2
        true
        testpilot@labs.mozilla.com

        Restartless Restart
        9
        true
        restartless.restart@erikvold.com

  Important Modified Preferences

      Name

      Value

        browser.cache.disk.capacity
        358400

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size.use_old_max
        false

        browser.cache.disk.smart_size_cached_value
        276480

        browser.places.smartBookmarksVersion
        4

        browser.startup.homepage_override.buildID
        20130506154904

        browser.startup.homepage_override.mstone
        21.0

        browser.tabs.warnOnClose
        false

        dom.mozApps.used
        true

        dom.w3c_touch_events.expose
        false

        extensions.lastAppVersion
        21.0

        gfx.direct3d.prefer_10_1
        true

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        22931

        plugin.disable_full_page_plugin_for_types
        application/pdf

        privacy.sanitize.migrateFx3Prefs
        true

  Graphics

        Adapter Description
        NVIDIA GeForce GTX 560 Ti

        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

        Adapter RAM
        1023

        Device ID
        0x1200

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.2.9200.16433)

        Driver Date
        3-14-2013

        Driver Version
        9.18.13.1422

        GPU #2 Active
        false

        GPU Accelerated Windows
        1/1 Direct3D 10

        Vendor ID
        0x10de

        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti  )

        AzureCanvasBackend
        direct2d

        AzureContentBackend
        direct2d

        AzureFallbackCanvasBackend
        cairo

  JavaScript

        Incremental GC
        true

  Accessibility

        Activated
        false

        Prevent Accessibility
        0

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9.6
        4.9.6

        NSS
        3.14.3.0 Basic ECC
        3.14.3.0 Basic ECC

        NSSSMIME
        3.14.3.0 Basic ECC
        3.14.3.0 Basic ECC

        NSSSSL
        3.14.3.0 Basic ECC
        3.14.3.0 Basic ECC

        NSSUTIL
        3.14.3.0
        3.14.3.0
Flags: needinfo?(ionel.mc)

Comment 12

5 years ago
Safe Mode also disables the JavaScript JIT compilers, and this crash has EnterIon in the signature, which is a JIT function.

Comment 13

5 years ago
(In reply to Ionel Maries from comment #11)
> What about firefox 21.0 (the beta) ?
See comment 1.

> Here's the latest crash: https://crash-stats.mozilla.com/report/index
> /bp-e020bdc6-6a41-4e28-9d34-2278a2130510
It's the right one.
Crash Signature: [@ je_malloc | arena_run_dalloc | arena_run_dalloc | je_free | EnterIon ] → [@ mozilla::WebGLContext::TexImage2D_base(unsigned int, int, unsigned int, int, int, int, int, unsigned int, unsigned int, void*, unsigned int, int, mozilla::WebGLTexelConversions::WebGLTexelFormat, bool) ]
Component: Extension Compatibility → Canvas: WebGL
Product: Firefox → Core
Summary: [@ je_malloc | arena_run_dalloc | arena_run_dalloc | je_free | EnterIon ] google webgl maps crashes browser while dragging route → google webgl maps crash in mozilla::WebGLContext::TexImage2D_base while dragging route
(Reporter)

Comment 14

5 years ago
I've tested aurora, crash details here: http://crash-stats.mozilla.com/report/index/bp-691617f4-f77b-45f2-aa0e-0d5462130510

Doesn't seem to reproduce on nightly. Perhaps the fix can be back-ported to the beta/stable ?
Ionel, can you find the first Nightly where this became fixed?
(Reporter)

Comment 16

5 years ago
Anthony, well, I could but it would take me unjustifiable amounts of time and I can use google maps just fine without webgl ...
Fair enough. Since this works on Nightly for you I'm going to resolve this WORKSFORME. If you change your mind and want to find a fix range before we release Firefox 23 (in 12 weeks) please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.