Contacts: Fully integrate PhonenumberJS when we save contacts

RESOLVED FIXED in Firefox 23

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: reuben, Assigned: gwagner)

Tracking

Trunk
mozilla23
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:leo+, firefox21 wontfix, firefox22 wontfix, firefox23 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(2 attachments, 2 obsolete attachments)

Reporter

Description

6 years ago
No description provided.
Reporter

Comment 1

6 years ago
Posted patch Normalize search.tel (obsolete) — Splinter Review
We don't need to store both versions because filterValue was being normalized before searching. Also includes some cleanup of makeImport.
Attachment #742399 - Flags: review?(anygregor)
Reporter

Updated

6 years ago
Attachment #742399 - Flags: review?(anygregor)
Reporter

Comment 2

6 years ago
Posted patch Normalize search.tel (obsolete) — Splinter Review
Attachment #742399 - Attachment is obsolete: true
Attachment #742401 - Flags: review?(anygregor)
Reporter

Updated

6 years ago
Attachment #742401 - Attachment is obsolete: true
Attachment #742401 - Flags: review?(anygregor)
Assignee

Updated

6 years ago
Summary: Contacts: |search.tel| should be normalized → Contacts: Fully integrate PhonenumberJS when we save contacts
Assignee

Comment 3

6 years ago
Posted patch patchSplinter Review
Assignee

Updated

6 years ago
Blocks: b2g-contact
Assignee

Updated

6 years ago
Blocks: 859185
Assignee

Comment 4

6 years ago
We didn't fully integrate PhoneNumberJS when saving contacts. The problem is when we import contacts from other sources like google or facebook. The numbers can contain random spaces that we can't enter with our keyboard.
This patch allows us to handle lookups for such contacts correctly.
blocking-b2g: --- → leo?
Reporter

Updated

6 years ago
Assignee: reuben.bmo → anygregor
Assignee

Updated

6 years ago
Attachment #742450 - Flags: review?(reuben.bmo)
Reporter

Comment 5

6 years ago
Comment on attachment 742450 [details] [diff] [review]
patch

Review of attachment 742450 [details] [diff] [review]:
-----------------------------------------------------------------

This is a happy day for ContactDB.makeImport! :)
Attachment #742450 - Flags: review?(reuben.bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/7a271620a508
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Duplicate of this bug: 865164
Assignee

Updated

6 years ago
Blocks: 862742
Assignee

Updated

6 years ago
Blocks: 864695
Blocking a blocker => leo+
blocking-b2g: leo? → leo+
This is going to need a branch-specific patch for uplift.
Flags: needinfo?(anygregor)
Assignee

Comment 11

6 years ago
Posted patch b2g18 patchSplinter Review
Flags: needinfo?(anygregor)
Duplicate of this bug: 857460
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.