crash in mozilla::dom::UnregisterPannerNodeOn

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: scoobidiver, Assigned: Ehsan)

Tracking

({crash, regression})

23 Branch
All
Windows 7
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox22 unaffected, firefox23 unaffected)

Details

(crash signature)

(Reporter)

Description

6 years ago
It first showed up in 23.0a1/20130426. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=690b5e0f6562&tochange=a6104e0e5a2c
It's likely a regression from bug 865548.

Signature 	mozilla::dom::UnregisterPannerNodeOn More Reports Search
UUID	ed108550-a909-4f33-a1dc-e93292130426
Date Processed	2013-04-26 15:00:53
Uptime	44
Last Crash	1.0 minutes before submission
Install Age	44 seconds since version was first installed.
Install Time	2013-04-26 14:56:12
Product	Firefox
Version	23.0a1
Build ID	20130426030834
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 37 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address	0x1e97f150
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0042, AdapterSubsysID: 305917aa, AdapterDriverVersion: 8.15.10.2622
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
Processor Notes 	sp-processor09.phx1.mozilla.com_11675:2012
EMCheckCompatibility	True
Adapter Vendor ID	0x8086
Adapter Device ID	0x0042
Total Virtual Memory	4294836224
Available Virtual Memory	3399364608
System Memory Use Percentage	47
Available Page File	5808300032
Available Physical Memory	2079956992

Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::dom::UnregisterPannerNodeOn 	content/media/webaudio/AudioContext.cpp:262
1 	xul.dll 	nsTHashtable<mozilla::dom::DOMStorageManager::DOMStorageCacheHashKey>::s_EnumStu 	obj-firefox/dist/include/nsTHashtable.h:486
2 	xul.dll 	PL_DHashTableEnumerate 	obj-firefox/xpcom/build/pldhash.cpp:714
3 	xul.dll 	nsTHashtable<mozilla::plugins::DeletingObjectEntry>::EnumerateEntries 	obj-firefox/dist/include/nsTHashtable.h:237
4 	xul.dll 	mozilla::dom::AudioContext::UpdatePannerSource 	content/media/webaudio/AudioContext.cpp:276
5 	xul.dll 	mozilla::dom::AudioNode::Disconnect 	content/media/webaudio/AudioNode.cpp:213
6 	xul.dll 	mozilla::dom::AudioNodeBinding::disconnect 	obj-firefox/dom/bindings/AudioNodeBinding.cpp:102
7 	xul.dll 	mozilla::dom::AudioNodeBinding::genericMethod 	obj-firefox/dom/bindings/AudioNodeBinding.cpp:207
8 	xul.dll 	XPCConvert::NativeData2JS 	js/xpconnect/src/XPCConvert.cpp:325
9 	mozjs.dll 	EnterBaseline 	js/src/ion/BaselineJIT.cpp:154
10 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:340
11 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:421
12 	mozjs.dll 	js::Invoke 	js/src/jsinterp.h:134
13 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:1031
14 		@0x393f94 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Adom%3A%3AUnregisterPannerNodeOn
(Assignee)

Comment 1

6 years ago
This is probably caused by bug 865550, since we would sometimes fail to unregister an AudioBufferSourceNode properly, which could cause this kind of crash if it's accessed later on.

I landed that bug on inbound yesterday, we should wait for it to make its way into a Nightly and then wait a few days to see if the crash disappears.
Blocks: 779297
Depends on: 865550
(Assignee)

Comment 2

6 years ago
Bug 865550 is on the latest Nightly now.
Assignee: nobody → ehsan
(Reporter)

Comment 3

6 years ago
There have been no crashes since 23.0a1/20130427.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox23: affected → unaffected
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

5 years ago
Mass moving Web Audio bugs to the Web Audio component.  Filter on duckityduck.
Component: Video/Audio → Web Audio
You need to log in before you can comment on or make changes to this bug.