global history is not updated over night

RESOLVED INVALID

Status

()

Core
History: Global
RESOLVED INVALID
17 years ago
a year ago

People

(Reporter: rkuhn, Unassigned)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-4GB i686; en-US; rv:0.9.1)
Gecko/20010607
BuildID:    2001060713

When mozilla is open over night the global history does not reflect the aging of
the entries correctly. If e.g. there were no entries in '2 days ago' the new
entries in there are not accessible until a restart of mozilla

Reproducible: Always
Steps to Reproduce:
1. create new global history
2. surf some pages
3. wait till next day

Actual Results:  Yesterday is not accessible

Expected Results:  Yesterday should contain the pages of the last day

Comment 1

17 years ago
related: bug 55293

Comment 2

17 years ago
actually, you shouldn't need to restart - you should just be able to collapse
and re-expand the "Yesterday" or "Today" folders, and the search is done in real
time... can someone confirm the behavior is actually as described?

(by the way, the related bug has to do with pages /expiring/, not displaying in
the UI)

Comment 3

17 years ago
I just tried this out with build 2001061823 on Windows 95.

I first took a look at the contents of my history in the sidebar. Both today and
yesterday looked correct.

I then set my system time to 11:58 PM, and amused myself elsewhere for two minutes.

After my computer thought that midnight had passed, I looked at my sidebar
again, expanded Today, and saw that it was empty, expanded yesterday, and saw
the things which had previously been in today

So far, so good.

I then proceeded to browse to a couple of sites that I was certain I had not
visited at all recently, http://luddite.com and http://snes9x.com

I then checked my today and yesterday history thingies in the sidebar. today was
still empty, and both http://luddite.com and http://snes9x.com had been added to
the yesterday category

Comment 4

17 years ago
Can I ask how you amused yourself for those two minutes?

Comment 5

17 years ago
um... well, I spun around on my spinny office chair a couple times, went to get
a drink of water from the cooler down the hall, and then came back and stared at
my telephone for a bit, hoping it would ring. It didnt.

If I knew all that was so important for reproducing the bug, I would have
mentioned it in the first place :)

Comment 6

17 years ago
were the dates for the sites you visited current? I'm curious if we're
miscalculating the visit date.

Comment 7

17 years ago
ooh! very good point! If Mozilla is using the dates that the servers sent me in
their headers, then the behavior I observed was exactly correct... but if
Mozilla is supposed to be using my computer's system date then it was wrong.

Ill try the same test again, next time I am actually using Mozilla when
real-life midnight rolls around and the pages I pull will actually be giving me
post-midnight dates, but I dont know when that will be, as I am terribly sleepy
at the moment 

Comment 8

17 years ago
actually, that wasn't quite what I was thinking :)
global history doesn't have access to the date sent by the server - it just uses
the "current" time - but what we basically do is keep a timestamp that we update
every so often (every few seconds) - but maybe that update is broken or something.

Comment 9

17 years ago
in keeping with the movement to "keep the unconfirms under control" I'd like to
suggest that we confirm this bug as no one is really objecting and its falling
off the radar just floating in the unconfirmed void. :-)

Comment 10

17 years ago
Hmmm, I had a history with many entries for 'today' and none for 'yesterday'.
I let it sit open over night and then took a look at it the next day. 'Today'
would not update even after I expanded and collapsed the twisty - there was no
twisty for 'yesterday'. Only after I closed the Global History window did things
properly update.

So the bug is that the UI is not updating(because evidently the realtime search
isn't triggered) _even_ after you collapse/expand the twisty. I still think it's
a bug even if it did work after clicking the twisty.
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

17 years ago
argh.. take two at reassigning history bugs to new owner
Assignee: alecf → blakeross

Updated

17 years ago
Target Milestone: --- → Future

Comment 12

16 years ago
*** Bug 158061 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
Hi,
I can confirm this bug also on Mozila 1.3b Gecko/20030210 on Windows XP sp1. One
day after soem surfing I had left my browser open, on next morrning I just
closed accidentaly the browser and when I opened it again there were no any of
thouse links what I had visited last evening. All links what I have seen before,
probably during the day were there, but those from last start of mozilla were gone.
Assignee: bross2 → nobody
QA Contact: claudius → history.global
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.