Error assistant sometimes covers top of screen and won't go away

RESOLVED FIXED

Status

Webmaker
Thimble
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Jacob, Assigned: pomax)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 742427 [details]
screenshot of UX frustration with error assistance

Sometimes when I make a mistake the error assistant displays at the top of the thimble editor, blocking my work. It doesn't go away and is super annoying, I sometimes can't fix the code that it's telling me to fix because it's in the way :-|

[attaching a screenshot]
(Assignee)

Comment 1

5 years ago
hm, this might need a simple "dismiss" link in the actual error box, in addition to disappearing when you hit [esc] or click the red circled !
(Assignee)

Updated

5 years ago
Assignee: nobody → pomax
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 769141
(Assignee)

Comment 3

5 years ago
Created attachment 743125 [details] [review]
https://github.com/mozilla/friendlycode/pull/190

filed a pull request against friendlycode to add in "dismiss" links for help and error messages, for in-dialog dismissal.
(Assignee)

Comment 5

5 years ago
both landed.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain text/plain → text/x-github-pull-request text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.