Inadequate window size for the download/sync pop-up box

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: sameerds, Assigned: dianesun)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Request R & SR)

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.1+) Gecko/20010617
BuildID:    2001061708

Clicking on file->offline->download/sync now opens up a dialog box with a number
of options. But the box is a little small so that the OK and Cancel buttons do
not show up. You have to drag the lower edge to make the box large enough for
these buttons to show.

Reproducible: Always
Steps to Reproduce:
1. Open the mail/news component
2. Click on the File menu and select offline->download/sync now...
3. Try to locate the OK button on the box that pops up.

Comment 1

17 years ago
Indeed the size is too small. I'll fix this.
Assignee: sspitzer → hwaara
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Mohan, I think your patch to remove the .xul and add nsIPrompt will fix this?

Comment 3

17 years ago
Ok, cleaning up the XUL a bit did it. Among some XUL cleanup I shrunk the space
the separators took (using class="thin") which in turn made the dialog a little
bit smaller.  I also made it so the OK/Cancel buttons adjusted a little better
to the window.

Adding patch and requesting r= from MohanB, Bhuvan or Dianesun.
Keywords: patch, review
OS: Windows 95 → All

Comment 4

17 years ago
Created attachment 40775 [details] [diff] [review]
fix. please review

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 5

17 years ago
*** Bug 81004 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: esther → gchan

Comment 6

17 years ago
Still need review and super-review.  Bhuvan? Seth?

Updated

17 years ago
Whiteboard: need review
(Assignee)

Comment 7

17 years ago
Just increase the number  in  msgSynchronize.xul   line 37
   width="???" height="???"

could solve the problem.
  

Comment 8

17 years ago
Well removing unused space is a much nicer solution IMHO. :) Even if both
solutions fixes it.

Comment 9

17 years ago
Looks ok to me.  Please make sure it looks right in all skins.
r=andreww
(Assignee)

Comment 10

17 years ago
Created attachment 41487 [details]
screenshot with new change
(Assignee)

Comment 11

17 years ago
I attached the screeshot with Hakan's changes. What do you think the lower half 
and the space between "Select" button and "OK/Cancel" buttons.

Comment 12

17 years ago
The only bad thing I can see there is the gap at the bottom. I'll make a new
patch to decrease the height of the dialog slightly.

Comment 13

17 years ago
Created attachment 41503 [details]
new screenshot...

Comment 14

17 years ago
Created attachment 41504 [details] [diff] [review]
... and of course new fix!

Comment 15

17 years ago
Dianesun, the new patch addresses your concern. Anything else?
(Assignee)

Comment 16

17 years ago
Looks good, please make sure the decrease in height works OK in any case. 
r=dianesun

Comment 17

17 years ago
Seth, got r=dianesun. Now waiting for your review to check this in.
seems fine to me.  sr=sspitzer

just a FYI, this dialog looked fine on my system before this change.

perhaps it might be display resolution / font specific.

maybe with certain large fonts, certain localizations, or certain display 
resolutions, the problem will still exist.

should we not be specifying the size, and sizing the dialog to the content?
(or am I missing something, and it will already size to content?)

Comment 19

17 years ago
Well, we should size to the content in many places but I think sizeToContent()
is horked.  This fix can't hurt.

Do you want me to add the sizeToContent() even though I'm not sure it will help
or even work?
proceed with your fix as-is, it doesn't make things worse.  (and looks like it 
makes things better in certain cases.)

don't add a sizeToContent() if you think it is broken.  (is there a bug on 
this?)

my really question is:

what is XPToolkit's recommend approach for problems like this?

1)  don't specify height & width (will it size to content on its own?)
2)  use (or don't use) sizeToContent() because...

cc danm, he'd be the one to know.

Comment 21

17 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 22

17 years ago
Using commercial trunk builds
2001071004 Win Nt 4.0
2001071008 linux 2.2, red hat 7.0
2001071008 mac os 9.0.4

Verified the Download/Sync Now window does not have cropped
ok and cancel buttons.

Tried in both modern and classic themes.

Tried different screen resolutions: 1024x768,800x600,600x480 
and no problems.

Marking as verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 23

17 years ago
Created attachment 42313 [details]
screenshot for the classic theme
(Reporter)

Comment 24

17 years ago
The problem still exists for the classic theme. Using build 20010713 on Windows.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 25

17 years ago
I noticed that the real problem here is that the dialog is resizable... 

I will try and re-fix this in a better way by using sizeToContent() and make the
dialog non-resizable.

Comment 26

17 years ago
Reassign to dianesun.
Assignee: hwaara → dianesun
Status: REOPENED → NEW
(Assignee)

Comment 27

17 years ago
Created attachment 45321 [details] [diff] [review]
Fix the size
(Assignee)

Comment 28

17 years ago
Request R & SR
Whiteboard: need review → Request R & SR

Comment 29

17 years ago
(about Diane's patch:) I dunno ... I disagree that the dialog should have a 
hardwired size at all. Regardless, it looks to be already fixed to me (a little 
too large, really). I've tried it on Linux and Windows in Classic and Modern 
skins; no clipping anywhere.

Comment 30

17 years ago
this is in response to Diane's email to me asking
me just to check how the current build looks like.

Did a quick look at 
2001-08-10-10-trunk NT 4.0 
2001-08-10-08-trunk/ linux 2.2, mac 9.0.4

Tried a 4.x profile and new profile, tried both modern
and classic themes, and different resolutions (640x840,800x600, and 1024
x 768). 

The Download and Sync Now window
looks fine. The Ok, cancel, and select buttons were not
cut off. The window is still resizeable.

But I said the same thing in my comments on 2001-07-10
and Ashant was still seeing the problem when I did not.

So I'm not sure 'what the problem is'. Certain 4.x profiles,
screen size, themes, etc..

I have seen in the past the Download and Sync now window
tiny and it cuts off the buttons (but I have not
recently seen this). So I don't know if the problem is
more than just code for the actual window and maybe something
else is affecting it?

So Diane it looks fine for me in the current builds. I'll
let Senior people here decide if we should mark this as
works for me or apply the patch.


(Assignee)

Comment 31

17 years ago
Thanks a lot, Gary.
Close it as "WORKSFORME"
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.