Firefox 20 breaks several applications utilizing java

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: John Fulton, Unassigned)

Tracking

({regression})

20 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

We utilize Firefox for several applications internal to our company (a phone company) from our financial database (JD Edwards) to GUI frontends to our phone switches and DSL DSLAMS.


Actual results:

After installation of Firefox 20, accessing JD Edwards GUI allows us to login, but launching java application in the GUI fails. Also the GUI frontend to our Calix B class DSL DSLAM blades fails to load. And our GUI frontend to our Comtech satellite modems no longer updates. We rolled back to Firefox 19 and everything starts working fine again.


Expected results:

For JD Edwards, the selected module should have loaded a subwindow in the browser for adding accounting data. In the Calix B blade GUI, the java application hangs and won't display the interface, and the Comtech modems will not update the status on the monitoring pages.

Updated

5 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
Hardware: x86_64 → x86
We have no access to those Java applications and that makes it difficult to solve the issue.
Could you try to find a regression range for us ?
We have a automated tool for this but it requires some software: 
http://mozilla.github.com/mozregression/

Updated

5 years ago
Flags: needinfo?(eldorin)
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 2

5 years ago
Last good nightly: 2012-11-19
First bad nightly: 2012-11-20

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4fddb9923ef0&tochange=bc69705c162d
Flags: needinfo?(eldorin)

Comment 3

5 years ago
There are three possible culprits: bug 800018, bug 810494 or bug 548133.
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

5 years ago
Is there any further testing that I can do to help isolate the problem?
(In reply to Scoobidiver from comment #3)
> There are three possible culprits: bug 800018, bug 810494 or bug 548133.

It's odd that this would affect Java, as these all deal with what to do when a plugin type is missing or cannot be loaded. This range also includes the 19 -> 20 version bump, I wonder if these apps are all using some common library with a UA sniffing issue.

(In reply to John Fulton from comment #4)
> Is there any further testing that I can do to help isolate the problem?

Can you give this build a try and let me know if it reproduces this issue?

https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jschoenick@mozilla.com-23eb8324a895/
(Reporter)

Comment 6

5 years ago
It works fine with that build.
(In reply to John Fulton from comment #6)
> It works fine with that build.

Can you give these two builds a shot as well, to narrow down the culprit?

https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jschoenick@mozilla.com-eb444d5e8761/

https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jschoenick@mozilla.com-2e18bd1689ef/
(Reporter)

Comment 8

5 years ago
Both of those do not work.

In the JD Edwards web GUI, it's pretty evident that it's not going to work because when you hover over a expandable menu item it is not selectable. But you can click on the menu expanding triangle to the left of the menu item to open it. When you finally get to the module to run and select it, it just says "Opening Application" with a spinning circle and sits there. When it works normally, you can either select the triangle or the expandable menu item to expand the selection and when you click on a module, you see the "Opening Application" for about a second and then that financial module opens.
(In reply to John Fulton from comment #8)
> Both of those do not work.
> 
> In the JD Edwards web GUI, it's pretty evident that it's not going to work
> because when you hover over a expandable menu item it is not selectable. But
> you can click on the menu expanding triangle to the left of the menu item to
> open it. When you finally get to the module to run and select it, it just
> says "Opening Application" with a spinning circle and sits there. When it
> works normally, you can either select the triangle or the expandable menu
> item to expand the selection and when you click on a module, you see the
> "Opening Application" for about a second and then that financial module
> opens.

If those work, that narrows the range down to:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4fddb9923ef0&tochange=669ac8371d19

Which has no obvious plugin changes, but includes the 19 -> 20 version bump.

Here is 4fddb9923ef0, the last good nightly, with the version bump applied directly to it (I just pushed this so the build might not appear for a few minutes yet):

https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jschoenick@mozilla.com-3968c0fe7b94/

If that fails, the issue is likely a java library common to these applets looking at firefox's UA string. We've had other bugs where code was looking for "Firefox/2" matching "Firefox/20.0", then assuming some quirk or feature that no longer exists.
(Reporter)

Comment 10

5 years ago
Yes, that version fails.

So I'm dealing with a applet problem that is misreading the version string. We've had to back-install the company to 19.0.2 and disable auto updating to maintain compatibility with our software. Until the software company fixes it, which updates the UI quite infrequently, is there a way to falsify that version string to the java library?
I didn't check it but you could try to use the general useragent override function.

http://www.howtogeek.com/113439/how-to-change-your-browsers-user-agent-without-installing-any-extensions/

Just enter the Firefox19 Useragent string in the preference
(Reporter)

Comment 12

5 years ago
I reinstalled 21.0, added general.useragent.override to the config with the string:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

And all my applications work fine now. Thank you all for the great help tracking this down.
Do not forget to remove this string in the future in case you want to use it as workaround or you will get issues on some websites.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.