Closed Bug 866376 Opened 7 years ago Closed 7 years ago

A new settings icon for 'Enable USB Storage' (replacing current placeholder Airplane icon)

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE3 (26jun)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: jj.evelyn, Assigned: arthurcc)

References

Details

(Whiteboard: [TD-41730], TaipeiWW, NeedsReview)

Attachments

(6 files)

Per Casey's design for new storage related settings, we need an icon for displaying 'Enable USB Storage'. Please refer the wireframe here (page 7):
https://www.dropbox.com/s/lr35b241542fmbu/Storage_v0.1.pdf
The new icon is for place A.
nominate leo+ because it blocks a loe+ (bug 856782)
Blocks: 856782
blocking-b2g: --- → leo?
Blocking a required 1.1 feature.
blocking-b2g: leo? → leo+
Not sure who can help on this issue, so ni UX group.
Assignee: padamczyk → nobody
Flags: needinfo?(firefoxos-ux-bugzilla)
@Arthur, please help on following up this issue. Thanks.
having airplane mode icon displayed for enabling USB storage... doesn't look right, is it temporary?
Going to reassign from general UX to Francis since this is Leo blocking. Francis, please feel free to reassign as appropriate.
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(fdjabri)
Hi Peter, could you help us with an icon for Enabling USB storage?
Flags: needinfo?(fdjabri) → needinfo?(pla)
(In reply to nkot from comment #5)
> Created attachment 748303 [details]
> airplane mode icon for USB storage
> 
> having airplane mode icon displayed for enabling USB storage... doesn't look
> right, is it temporary?

yes, so I file this issue for UX support on a correct icon.
Assignee: nobody → arthur.chen
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
(I nearly filed a duplicate bug about the airplane icon being used for USB storage, and then I discovered this existing bug just in time. --> Updating bug-summary to mention "airplane" to make this bug more searchable for anyone else who runs into this.)
Summary: A new settings icon for 'Enable USB Storage'. → A new settings icon for 'Enable USB Storage' (replacing current placeholder Airplane icon)
Do we have the correct icon yet? This is leo+ and needs to move. Thanks!
Attached image Icon
Apologies for the delay.  Attached is the icon.
Flags: needinfo?(pla)
Peter, thanks for the icon.
Could you help put the icon to the sprites? (the path is /apps/settings/style/images/icons_sprite.gif, icons_sprite_active.gif) And it would be great if you can also provide the 2X version of the tow sprites. Thanks!
Flags: needinfo?(pla)
Whiteboard: [TD-41730]
Target Milestone: --- → 1.1 QE3 (24jun)
Attached are two files - icons_sprite.gif and icons_sprite@2x.gif - with the new icon placed at the end.

Eric, can you review the @2x version and tell me if the transparency is ok?  I'm not familiar with why it's being done with transparency when the normal version has a solid grey background.  The edges look really rough to me, but this would be ok if it's only going to appear on a white background.

Thanks!
Attachment #763272 - Flags: feedback?(epang)
Flags: needinfo?(pla)
Attached image icons when active
Thanks for the effort, Peter! For better performance, we avoided to use transparent images for the icons. That's why we have another image sprite with a background color for active items as the attachment shows.

It would be appreciated if you can provide the active icon sprite or the source file of the sprite with transparent background, so that we can generate corresponding sprites. Also, I've noticed that the 2x version of the display icon (the sun symbol) is a little bit rotated compared with the normal version.
Flags: needinfo?(pla)
Attached file Setting Sprites
Hi Arthur, here are sprites for settings in both normal & action states (in normal and @2x sizes).

When in the folders on gaia we noticed that the @2x version had a transparent background, is this needed or is what I'm providing correct?  Please let me know if a transparent version or anything else is needed!  Thanks!
Flags: needinfo?(pla)
Eric, thanks for helping! The transparent background of the original 2x version file is wrong.

Evelyn, please help review the change, thanks!
Attachment #763957 - Flags: review?(ehung)
Whiteboard: [TD-41730] → [TD-41730], TaipeiWW, NeedsReview
Comment on attachment 763957 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/10450

r=me, thanks for your follow-up work! :)
Attachment #763957 - Flags: review?(ehung) → review+
Thanks for reviewing, Evelyn. 

master: https://github.com/mozilla-b2g/gaia/commit/05c03cbf2a25e417116665273aa8ee809c48e3fc
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 05c03cbf2a25e417116665273aa8ee809c48e3fc
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(arthur.chen)
v1-train: d8d189b6a23adf1b492a0c325ab8f3fdbfbf7ad4
Flags: needinfo?(arthur.chen)
1.1hd: d8d189b6a23adf1b492a0c325ab8f3fdbfbf7ad4
In v1-train, is it ok to use rem instead of px?

#menuItem-battery::before {
  background-position: -120px -90px;
}

#menuItem-enableStorage::before {
  background-position: -6rem -15rem;
}

#menuItem-applicationStorage::before {
  background-position: 0 -120px;
}
Based on the font size configuration of the root element in v1-train, 1 rem equals 10 pixel. It is okay while the code looks inconsistent. I'll refine it in an appropriate patch.
Duplicate of this bug: 891278
Attachment #763272 - Flags: feedback?(epang)
You need to log in before you can comment on or make changes to this bug.