bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[OPEN_]It does not have ringtone when receiving an Unknown number call and can not answer this call.

VERIFIED FIXED in 1.0.1 Cert2 (21may)

Status

Firefox OS
Gaia::Dialer
P1
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Firefox_Mozilla, Assigned: gtorodelvalle)

Tracking

unspecified
1.0.1 Cert2 (21may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.1 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Steps to reproduce:
1. close Caller Identification;
2. use other phone to make a call to Firefox phone;
Expected:
1. it has ringtone and can answer or reject this call;
Actual:
1.it does not have ringtone when receiving a call;
2.it does not have "Unknown number" shown in screen but only has a blue area in screen;
3.when we tap button to answer the call, it does not have feedback. we only can reject this call. And after reject the call, it does not have call log in Dialer.

build ID:20130426165700
build information:
gaia commit:
e25b349 Merge pull request #9273 from gasolin/issue-863126
gecko commit:
6dfd179 Bug 849757 - Part 4: xpcshell tests. r=vicamo, a=tef+
gaia commit:
e25b349 Merge pull request #9273 from gasolin/issue-863126
gecko commit:
6dfd179 Bug 849757 - Part 4: xpcshell tests. r=vicamo, a=tef+
AU:V1.01.00.01.019.085
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
This is indeed a regression, as it doesn't occurr in previuos releases, but it is an important issue

Testing with version reported in description you can reproduce the issue, but testing with (for instance) 
   Buildid "20130321070205"
   gecko commit: b5183c99228bdc5be33340e359efd1b4f0859e92 
   gaia commit: 577d13088ebdbd353d13910d3317e713a140415b
this issue is not present.
Severity: normal → critical
Priority: -- → P1
Could this have to do with the changes in the type for MCC/MNC?
Blocks: 855322, 855378
blocking-b2g: tef? → tef+
Flags: needinfo?(gtorodelvalle)

Updated

5 years ago
Duplicate of this bug: 865967

Comment 4

5 years ago
Ken, do you have any comments on this bug? Thanks.
Flags: needinfo?(kchang)

Updated

5 years ago
Target Milestone: --- → 1.0.1 Cert2 (28may)

Comment 5

5 years ago
Hi, could you please help to provide log for analysis?
1. Device log:  adb logcat -v threadtime > foo.log
2. Radio log: adb logcat -v threadtime -b radio > foo_radio.log
Thanks
Assignee: nobody → gtorodelvalle
Hi guys! Although I do not really get the first step to reproduce the bug (1. close Caller Identification;) I have confirmed that with an Unagi device and using the latest code from the v1.0.1 (as for now), the Unagi receives the calls providing information about the calling party or showing "Unknown number" if the calling party hides its number (#31#666666666, for example).

Am I doing something wrong here or it no longer happens? Thanks!
Flags: needinfo?(gtorodelvalle) → needinfo?(Firefox_Mozilla)
(In reply to gtorodelvalle from comment #6)
> Hi guys! Although I do not really get the first step to reproduce the bug
> (1. close Caller Identification;) I have confirmed that with an Unagi device
> and using the latest code from the v1.0.1 (as for now), the Unagi receives
> the calls providing information about the calling party or showing "Unknown
> number" if the calling party hides its number (#31#666666666, for example).
> 
> Am I doing something wrong here or it no longer happens? Thanks!

Are you testing with Commercial or with the opensource one?
I am using the default one so I guess that's the open source one... Talking to Marcos to try it with the commercial one. Thanks!
It does reproduce using the commercial RIL:
E/GeckoConsole( 1107): [JavaScript Error: "TypeError: number is null" {file: "app://communications.gaiamobile.org/dialer/js/handled_call.js" line: 103}]

The problem is that with the open source RIL, the number property of the call object is a string which comes as '' (length 0) when the calling party does not provide its phone number whereas with the commercial RIL, the number property of the call object is an object which comes to null when the calling party does not provide its phone number.

Shall I adapt the code in Gaia to correctly manage both cases or should this be solved at a RIL layer? Thanks!
Flags: needinfo?(dcoloma)
Whiteboard: [POVB],[COM_RIL]
Flags: needinfo?(Firefox_Mozilla)

Comment 10

5 years ago
(In reply to gtorodelvalle from comment #9)
> It does reproduce using the commercial RIL:
> E/GeckoConsole( 1107): [JavaScript Error: "TypeError: number is null" {file:
> "app://communications.gaiamobile.org/dialer/js/handled_call.js" line: 103}]
> 
> The problem is that with the open source RIL, the number property of the
> call object is a string which comes as '' (length 0) when the calling party
> does not provide its phone number whereas with the commercial RIL, the
> number property of the call object is an object which comes to null when the
> calling party does not provide its phone number.
> 
> Shall I adapt the code in Gaia to correctly manage both cases or should this
> be solved at a RIL layer? Thanks!

as an empty string is also falsy value I believe that would be an easy fix
Absolutely, in fact the problem is that we are accessing the length property of something which now comes to null with no control on it :-O I think the code should be improved to properly cope with both cases although I guess both RILs should behave the same way :-)
(In reply to gtorodelvalle from comment #11)
> Absolutely, in fact the problem is that we are accessing the length property
> of something which now comes to null with no control on it :-O I think the
> code should be improved to properly cope with both cases although I guess
> both RILs should behave the same way :-)

I think we should fix this in Gaia (add the control you mention) and hence remove the POVB/COM_RIL flags. Anyway, I agree that both RILs should behave in the same way. Michael, are you planning to change this in COM_RIL too?
Flags: needinfo?(dcoloma) → needinfo?(mvines)
Whiteboard: [POVB],[COM_RIL]
Created attachment 744521 [details]
Associated PR.

I have sent the pull request to master to have the control also there and afterwards uplifting it.
Attachment #744521 - Flags: review?(jmcf)
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected

Updated

5 years ago
Attachment #744521 - Flags: review?(jmcf) → review+
Merged in master: https://github.com/mozilla-b2g/gaia/commit/c247f1238c6cc7c845796a707982f79cdbc99418
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted c247f1238c6cc7c845796a707982f79cdbc99418 to:
v1-train: 1924996e4d9f7521ec7ace9fff602317c1ae1b03
v1.0.1: 716c192821f6528dfaa198c1e1526c464ed42ba9
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
Flags: needinfo?(mvines) → needinfo?(anshulj)

Comment 16

5 years ago
Danie, I wasn't planning to fix it in commercial RIL if you are fixing it in gaia. The reason is that in most places where the string is not available content process expects a null and so just for consistency I will like to keep it the as is. Please let me know if fixing in Gaia is not an option.
Flags: needinfo?(anshulj)
(In reply to Anshul from comment #16)
> Danie, I wasn't planning to fix it in commercial RIL if you are fixing it in
> gaia. The reason is that in most places where the string is not available
> content process expects a null and so just for consistency I will like to
> keep it the as is. Please let me know if fixing in Gaia is not an option.

oK, understood, this is already fixed in Gaia so the issue is not going to occur anymore. Thanks!

Comment 18

5 years ago
Verified fixed on Inari Build ID: 20130503070205
Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3f3489356bbc
Gaia: 3e232bce289c9e156d92553e752616cba284bc8f

Also verified fixed on Unagi Build ID: 20130503070205
Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3f3489356bbc
Gaia: 3e232bce289c9e156d92553e752616cba284bc8f 

A phone call received by an unknown number does have a ringtone, also rejecting an unknown call will show up in the call log.
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified

Updated

5 years ago
Flags: needinfo?(kchang)
You need to log in before you can comment on or make changes to this bug.