check box missing in column mode of add-on Adblock Plus

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: swstar, Assigned: gaubugzilla)

Tracking

({regression})

22 Branch
x86_64
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 unaffected, firefox22-, firefox23-)

Details

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20130426 Firefox/22.0
Build ID: 20130426004017

Steps to reproduce:

Opening adblock plus filter preference panel in order to enable/disable a filter


Actual results:

The check box is not displayed in the column mode in adblock plus filters, thus I can not enable/disable a filter.


Expected results:

The check box should be displayed.
Regression range:
good=2013-03-04
bad=2013-03-05
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=86c98c4d36da&tochange=015da7030aab
Blocks: abp
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: check box disappear in column mode → check box missing in column mode of add-on Adblock Plus
This problem is caused by Bug 407956.
So, the addon should be modified.
Blocks: 407956
Component: Untriaged → Extension Compatibility
Wladimir - do you accept Mozilla bugs?
Assignee: nobody → trev.moz
I do. I was looking into that issue already - thank you for tracking down the relevant API change.
Fixed:
https://hg.adblockplus.org/adblockplus/rev/083875fc8475
https://hg.adblockplus.org/abpwatcher/rev/a0a73f6e3696

The corresponding releases should be out by next Tuesday.
Adblock Plus 2.2.4 and Diagnostics 1.2.4 for Adblock Plus were released yesterday, that issue should be gone in both.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Posted image checkbox-screenshot
Wladimir, do you know if the new style of the checkboxes on the right is normal after your modification?
The checkbox style was always like that. Firefox doesn't style checkboxes in a tree widget at all, so you cannot have native styling. Adblock Plus uses checkbox images that look ok-ish on all platforms but don't match the native widgets on any platform of course.
(In reply to Wladimir Palant from comment #5)
> Fixed:
> https://hg.adblockplus.org/adblockplus/rev/083875fc8475
> https://hg.adblockplus.org/abpwatcher/rev/a0a73f6e3696
> 
> The corresponding releases should be out by next Tuesday.

Untracking given this. Thanks Wladimir.
You need to log in before you can comment on or make changes to this bug.