Last Comment Bug 866412 - Build failure: cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
: Build failure: cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 23.0
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on: 859817
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-27 07:11 PDT by Stefan Sitter
Modified: 2013-04-27 13:02 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch v1 (6.34 KB, patch)
2013-04-27 07:47 PDT, :Ms2ger (⌚ UTC+1/+2)
standard8: review+
Details | Diff | Splinter Review

Description Stefan Sitter 2013-04-27 07:11:06 PDT
After applying the bustage fix from Bug 864256 I ran into the following problem:

> .../mailnews/base/src/nsMsgFolderDataSource.cpp(186) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(187) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(188) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(189) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(190) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(191) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(192) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(193) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(194) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(195) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(196) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(197) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgFolderDataSource.cpp(198) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgAccountManagerDS.cpp(164) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsStatusBarBiffManager.cpp(58) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgDBView.cpp(152) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'
> .../mailnews/base/src/nsMsgDBView.cpp(153) : error C2440: '=' : cannot convert from 'already_AddRefed<T>' to 'nsIAtom *'

Probably caused by the check-in for Bug 859817 (Make NS_NewAtom return already_AddRefed).
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2013-04-27 07:47:13 PDT
Created attachment 742710 [details] [diff] [review]
Patch v1
Comment 2 Mark Banner (:standard8) 2013-04-27 10:13:42 PDT
Comment on attachment 742710 [details] [diff] [review]
Patch v1

Review of attachment 742710 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thanks.
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2013-04-27 10:44:03 PDT
https://hg.mozilla.org/comm-central/rev/271b24c7b667
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2013-04-27 13:02:57 PDT
And one more missed caller:

https://hg.mozilla.org/comm-central/rev/3d3e10b5c289

Note You need to log in before you can comment on or make changes to this bug.