The default bug view has changed. See this FAQ.

MOZ_UPDATER always set to true in AppConstants.java

RESOLVED FIXED in Firefox 23

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Chen Dai, Assigned: Chen Dai)

Tracking

unspecified
Firefox 23
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.20 (KHTML, like Gecko) Chrome/25.0.1337.0 Safari/537.20

Steps to reproduce:

set MOZ_UPDATER= in mobile/android/branding/unofficial/configure.sh


Actual results:

MOZ_UPDATER set to true in AppConstants.java


Expected results:

MOZ_UPDATER set to false in AppConstants.java

it should add ifdef XXX in android/base/Makefile.in before "-DMOZ_UPDATER=$(MOZ_UPDATER)"
Hi Chen, since you already found the cause of the issue, would you like to contribute a patch to fix it?
Blocks: 786380
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → Android
Hardware: x86 → ARM
(Assignee)

Comment 2

4 years ago
Created attachment 744100 [details] [diff] [review]
patch for bug866487

I made a patch for android

Updated

4 years ago
Attachment #744100 - Attachment is patch: true
Attachment #744100 - Flags: review?(snorp)
Attachment #744100 - Flags: review?(snorp) → review+

Updated

4 years ago
Assignee: nobody → daichen314
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/4c4810ef2092
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4c4810ef2092
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
You need to log in before you can comment on or make changes to this bug.