Closed Bug 866549 Opened 10 years ago Closed 9 years ago

Updating Mozilla Verbatim

Categories

(developer.mozilla.org Graveyard :: Localization, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ghost, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

Steps to reproduce:

Many URL was changed.
This affect to Mozilla Verbatim.

example: https://localize.mozilla.org/ja/mdn/translate.html?unit=1355670

I fixed them after checking all links.
However, many times other people rewrite to old URL...
Because, original string is wrong.

Please correct all old URLs in Mozilla Verbatim.
Thanks for reporting this, Ethertank. Jean-Yves, can you take a look?
Flags: needinfo?(jypenator)
John, I have no right other than user rights on Verbatim. Also I think verbatim doesn't point to the right Kuma version, I think.

We may try to reach the ja admistrator of Kuma but I don't know who there are (pascal may help but he is in PTO for one more week).
Flags: needinfo?(jypenator)
To be honest, I don't think I fully understand the problem. What would the ja administrator of Kuma be needed for?

Anyway, the admin is probably one of these people.
https://localize.mozilla.org/ja/mdn/

Ethertank, do you know who the ja administrator is?
Maybe, dynamis@mozilla-japan.org

But... I think this is not just problem of administrator of Japan.
If you can't do smooth communication with the administrator of "Mozilla Verbatim", you shouldn't move a lot of pages.
(In reply to John Karahalis [:openjck] from comment #5)
> To be honest, I don't think I fully understand the problem. What would the
> ja administrator of Kuma be needed for?

Ethertank says the probrem is in the en-US template.
Please update old URLs in the "messages.pot" template.
I wonder if this problem here is the one detected by the French localisation team that is blocking any localisation.

Basically, Verbatim is pointing to the wrong branch of Kuma and none of the new strings/URL/… does appear for translation.

This bug (which is rapported) is completely blocking all translation on the MDN.
You should check all URL in Mozilla Verbatim.

https://localize.mozilla.org/ja/mdn/translate.html?unit=1355628

<p>The Geolocation API lets you determine the location and movement of a user. What can you do with this information? Maps, social networking, games &mdash; the possibilities are endless. Looking for inspiration? Just take a look at some of the amazing things created for our <a href="https://developer.mozilla.org/en-US/demos/devderby/2011/september">first Geolocation Derby</a>.</p> <p>Anyone can learn to use the Geolocation API, especially considering how much documentation we already have on the topic. Beginners might like <a href="https://hacks.mozilla.org/2011/09/where-on-earth-this-months-developer-derby-is-all-about-geolocation/">this blog post</a> from our very own Christian Heilmann (complete with an interactive code sample), and experts might like the <a href="https://developer.mozilla.org/en-US/docs/Using_geolocation">even more detailed documentation</a> available on the MDN.</p> <p>The best part? You don't need to learn much to start using Geolocation on mobile devices right now. No Java, no Objective-C, no native SDKs. Just the web. And you already know how to use that, right?</p>

https://localize.mozilla.org/ja/mdn/translate.html?unit=1355556

<p>CSS Media Queries have come a long way in the last year. Now a <a href="http://www.w3.org/TR/css3-mediaqueries/">W3C Recommendation</a>, media queries help you support the ever-expanding variety of screen sizes and resolutions in use today. Smart phones and feature phones, tablets and e-book readers, short screens, tall screens, and super-high-resolution screens -- the Web is growing, shrinking, and changing every day.</p> <p>Building a Web app that works well across this spectrum can seem daunting, but we have you covered. Take a look at this <a href="http://css-tricks.com/css-media-queries/">introduction</a> from former Derby judge Chris Coyier and be sure to head over to the MDN for <a href="https://developer.mozilla.org/en-US/docs/CSS/Media_queries">more depth and more up-to-date information</a> after that. Need help testing your creation? The new <a href="https://developer.mozilla.org/en-US/docs/Tools/Responsive_Design_View">Responsive Design View</a> of Firefox Developer Tools makes debugging responsive web designs fast, easy, and fun.</p> <p>Some <a href="https://developer.mozilla.org/en-US/demos/devderby/2011/october">great demos</a> were shared in our last Derby on this topic. What can you do with CSS Media Queries?</p>

I modified outdated URL when translating.
However, fools undo them because URLs in original is wrong.
Alright, double-checking what's to be done here.

One needs to go through the strings and check if the URL is the most recent one (so basically, under /docs/Web or /docs/WebAPI and update the stale /en/ to /en-US/), right?

Let's just hope that the strings will be marked as fuzzy translations in verbatim so that localizers won't have to start all over again with the modified strings :)
Flags: needinfo?(ghost)
Flags: needinfo?(ghost)
Commit pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/7c983dd8f7e23df9cfb49c5862c2ecc8d2b7f8f4
Merge pull request #1277 from FredericBourgeon/update-strings

fix bug 866549 - Updating strings to newest
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: developer.mozilla.org → developer.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.