cant read the first site of TopSitesView in screen reader

RESOLVED FIXED in Firefox 26

Status

()

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: daichen314, Unassigned)

Tracking

Trunk
Firefox 26
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130329030832

Steps to reproduce:

1. open google reader(google talkback), enable touch explore
2. open firefox
3. touch first site"Firefox: Support"


Actual results:

nothing happend.
reader can read Firefox Support, and highlight the item.


Expected results:

reader can read "Firefox Support", and highlight the item.

But touch the second site"Firefox: Customize with add-ons", it acted properly.
I think it maybe a layout issue.
Because in google reader, if touch first site, it received  girdview accessibility events with no text. If touch second site, it received  RelativeLayout accessibility events with text"Firefox: Customize with add-ons".
The awesome screen is made up of native widgets AFAIK. This would be a rather peculiar widget bug, then. Eitan, any ideas?
OS: Linux → Android
Hardware: x86_64 → ARM
Looping in the folks who work on this. This has been an issue for a while, even before AboutHomeConent was converted to a fragment.

Comment 3

5 years ago
No longer an issue in the new about:home.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.