Closed Bug 866615 Opened 7 years ago Closed 7 years ago

[Bluetooth] Reset is occurred when received video file via bluetooth OPP

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:tef+, firefox21 wontfix, firefox22 wontfix, firefox23 fixed, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 verified)

VERIFIED FIXED
blocking-b2g tef+
Tracking Status
firefox21 --- wontfix
firefox22 --- wontfix
firefox23 --- fixed
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- verified

People

(Reporter: leo.bugzilla.gecko, Assigned: echou)

References

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 file)

Dear Mozilla Team,

In our latest version, reset is occured when received video file via bluetooth OPP.
So, I have reviewed for latest patches, and I found a mismatch code.

====================================================
- BluetoothOppManager.cpp
mDsFile = new DeviceStorageFile(NS_LITERAL_STRING("movies"), storagePath);

- nsDeviceStorage.cpp
#define DEVICESTORAGE_VIDEOS     "videos"

// Video directory
else if (aType.EqualsLiteral(DEVICESTORAGE_VIDEOS)) {
====================================================

GetRootDirectoryForType function was added In nsDeviceStorage.cpp, 
and then bt side send string "movies" to DeviceStorageFile but DeviceStorage side define this string to "videos".
Eventually DeviceStorage is not matched the type, so reset is occurred during file writing.

This code is same as Mozilla-Central, maybe your device will be reproduced.
So, I modified the literal string from "movies" to "videos" and reset is not occurred.

Please check this code.

Thanks.
When I implemented this part of code, I thought the DeviceStorage media types were "pictures", "movies" and "music". However, "movies" should be replaced with "videos".
blocking-b2g: --- → tef?
OS: Windows XP → Gonk (Firefox OS)
Hardware: x86 → ARM
Blocking, assuming this also occurs in 1.0.1
blocking-b2g: tef? → tef+
Attachment #742971 - Flags: review?(doug.turner)
Attachment #742971 - Flags: review+
Attachment #742971 - Flags: approval-mozilla-b2g18+
Whiteboard: [needs landing?]
Whiteboard: [needs landing?] → [needs landing?][fixed-in-birch]
Duplicate of this bug: 867874
https://hg.mozilla.org/mozilla-central/rev/3968311ac65b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified fixed on Inari Build ID: 20130503070205
Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3f3489356bbc
Gaia: 3e232bce289c9e156d92553e752616cba284bc8f

Also verified fixed on Unagi Unagi Build ID: 20130503070205
Environmental  Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3f3489356bbc
Gaia: 3e232bce289c9e156d92553e752616cba284bc8f

Videos can be successfully sent and received via bluetooth without reset.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 870725
You need to log in before you can comment on or make changes to this bug.