Closed Bug 866619 Opened 7 years ago Closed 6 years ago

B2G RIL: mozMobileConnection.voice.state is 'registered' even in Airplane mode

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: allstars.chh, Assigned: edgar)

References

Details

Attachments

(2 files)

I found even in Airplane mode, voice.state is still 'registered'.

I/Gecko   (  108): -*- RILContentHelper: Received message 'RIL:VoiceInfoChanged': {"connected":false,"emergencyCallsOnly":true,"roaming":false,"network":{"rilMessageType":"operatorchange","mcc":null,"mnc":null,"longName":null,"shortName":null,"batch":true},"lastKnownMcc":"466","cell":null,"type":"gsm","signalStrength":null,"relSignalStrength":0,"state":"registered"}


From the parcel, the state is 2, which should be 
 2 - Not registered, but MT is currently searching a new operator to register

RadioInterfaceLayer: Received message from worker: {"rilMessageType":"cardstatechange","cardState":null}
I/Gecko   (  108): RIL Worker[0]: Received 92 bytes.
I/Gecko   (  108): RIL Worker[0]: Already read 0
I/Gecko   (  108): RIL Worker[0]: New incoming parcel of size 88
I/Gecko   (  108): RIL Worker[0]: Parcel (size 88): 0,0,0,0,5,0,0,0,0,0,0,0,15,0,0,0,1,0,0,0,50,0,0,0,255,255,255,255,255,255,255,255,1,0,0,0,48,0,0,0,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,1,0,0,0,48,0,0,0,255,255,255,255
I/Gecko   (  108): RIL Worker[0]: We have at least one complete parcel.
I/Gecko   (  108): RIL Worker[0]: Solicited response for request type 20, token 5, error 0
I/Gecko   (  108): RIL Worker[0]: Handling parcel as REQUEST_VOICE_REGISTRATION_STATE
I/Gecko   (  108): RIL Worker[0]: Received voiceRegistrationState network info.
I/Gecko   (  108): RIL Worker[0]: Still missing some more network info, not notifying main thread.
I/Gecko   (  108): RIL Worker[0]: voice registration state: 2,,,0,,,,,,,,,,0,
I/Gecko   (  108): RIL Worker[0]: Queuing voiceRegistrationState network info message: {"regState":2,"state":"registered","connected":false,"roaming":false,"emergencyCallsOnly":true,"cell":{"gsmLocationAreaCode":-1,"gsmCellId":-1},"radioTech":0,"type":null,"rilMessageType":"voiceregistrationstatechange"}
I/Gecko   (  108): RIL Worker[0]: Next parcel size unknown, going to sleep.


I think ril_const.js has wrong state mapping in 
http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_consts.js#2256
Yoshi, can you please help this issue? THX.
Assignee: nobody → allstars.chh
Duplicate of this bug: 819533
Stealing ...
Assignee: allstars.chh → echen
Attachment #778344 - Flags: review?(allstars.chh)
Attachment #778345 - Flags: review?(allstars.chh)
Attachment #778344 - Flags: review?(allstars.chh) → review+
Attachment #778345 - Flags: review?(allstars.chh) → review+
Keywords: checkin-needed
Blocks: 823903
https://hg.mozilla.org/mozilla-central/rev/260b5acd1940
https://hg.mozilla.org/mozilla-central/rev/68bcfde4e82a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Duplicate of this bug: 823903
You need to log in before you can comment on or make changes to this bug.