[Cost Control] Localization error for "Reset report Button" in Phone and Internet data report.

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: leo.bugzilla.gaia)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
1. Title : Localization error for "Reset report Button" in Phone and Internet data report.
2. Precondition : In FTE select the language other than English(US) and go to Settings - Language - Change the Language to English(US)
3. Tester's Action : Usage - Settings - Phone and Internet data report - Reset report
4. Detailed Symptom (ENG.) :The label on the Reset report button is not updated to English language.
6.Reproducibility: Y
1)Frequency Rate : 100%\
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 142dda6dfe500479c8cfba2bdcd3244b70434ea9
9.Personal email id: vsireesha246@gmail.com
(Assignee)

Comment 1

5 years ago
Created attachment 743442 [details]
Screenshot attached
(Assignee)

Comment 2

5 years ago
For "No SIM" case the alert is shown is wrong.Language is not updated properly.
The alert is shown as below in costcontrol app for no sim case. 
"widget-no-sim2-heading
widget-no-sim2-meta"
Flags: needinfo?(salva)
Hello!

There are to errors here. Please, let them be separated as this one:

> For "No SIM" case the alert is shown is wrong.Language is not updated
> properly.
> The alert is shown as below in costcontrol app for no sim case. 
> "widget-no-sim2-heading
> widget-no-sim2-meta"

is a duplicated for bug 863778.

Let me see the other.
Flags: needinfo?(salva)
(Assignee)

Comment 4

5 years ago
(In reply to Leo from comment #0)
> 1. Title : Localization error for "Reset report Button" in Phone and
> Internet data report.
> 2. Precondition : In FTU(First Time User exp) select the language other than English(US) and go
> to Settings - Language - Change the Language to English(US)
> 3. Tester's Action : Usage - Settings - Phone and Internet data report -
> Reset report
> 4. Detailed Symptom (ENG.) :The label on the Reset report button is not
> updated to English language.
> 6.Reproducibility: Y
> 1)Frequency Rate : 100%\
> 7.Gaia Master/v1-train : Reproduced
> 8.Gaia Revision: 142dda6dfe500479c8cfba2bdcd3244b70434ea9
> 9.Personal email id: vsireesha246@gmail.com
blocking-b2g: --- → leo?
tracking-b2g18: --- → ?
Tracking, not blocking.
blocking-b2g: leo? → -
status-b2g18: --- → affected
tracking-b2g18: ? → +
(Assignee)

Comment 6

5 years ago
Created attachment 752686 [details]
Pointer to pull request : https://github.com/mozilla-b2g/gaia/pull/9930

Please review the patch.
Attachment #752686 - Flags: review?(salva)
Comment on attachment 752686 [details]
Pointer to pull request : https://github.com/mozilla-b2g/gaia/pull/9930

Please, check comments on GitHub, fix and renominate for review.

Thank you!
Attachment #752686 - Flags: review?(salva) → review-
Assignee: nobody → leo.bugzilla.gaia
(Assignee)

Updated

5 years ago
Attachment #752686 - Flags: review-
(Assignee)

Updated

5 years ago
Attachment #752686 - Flags: review- → review?(salva)
Attachment #752686 - Attachment is patch: false
Attachment #752686 - Attachment mime type: text/plain → text/html
Comment on attachment 752686 [details]
Pointer to pull request : https://github.com/mozilla-b2g/gaia/pull/9930

You have a little indentation problem. Please, solve it before merging.
Thank you for your smart solution!
Attachment #752686 - Flags: review?(salva) → review+
(Assignee)

Comment 9

5 years ago
Indentation problem solved.Squashing is done.
Please review.
master: 8abc8d77776dae8c9f9f23a1494008e2ba4297b4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment on attachment 752686 [details]
Pointer to pull request : https://github.com/mozilla-b2g/gaia/pull/9930

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 841439
User impact if declined: medium (some words in other language)
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #752686 - Flags: approval-gaia-v1?
(Assignee)

Updated

5 years ago
tracking-b2g18: + → ?
(Assignee)

Comment 12

5 years ago
Please uplift to V1train.
Attachment #752686 - Flags: approval-gaia-v1? → approval-gaia-v1+
tracking-b2g18: ? → +
Uplifted 8abc8d77776dae8c9f9f23a1494008e2ba4297b4 to:
v1-train: 87ba02ceaa3bc2648f70df2321cfb6b809acc0d9
status-b2g18: affected → fixed
You need to log in before you can comment on or make changes to this bug.