bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Dumps core on startup in JS_ARENA_ALLOCATE_TYPE



Build Config
17 years ago
14 years ago


(Reporter: Ryan Hankins, Assigned: cls)




Firefox Tracking Flags

(Not tracked)




17 years ago
Occurs on multiple machines.

Using Mozilla 0.9, built from source using MipsPRO compilers.

Since ale = 0, it would appear that JavaScript is out of memory before this is
called.  Perhaps there should be an assert for this in the allocate.

[hankins@clink bin]$ ./mozilla
./run-mozilla.sh ./mozilla-bin


*** Registering nsCookieModule components (all right -- a generic module!)
nsNativeComponentLoader: autoregistering succeeded
moz_run_program[36]: 108543 Bus error(coredump)

Oh no!  ./mozilla-bin just dumped a core file.

Do you want to debug this ? You need a lot of memory for this, so watch out ?
[y/n] y

/bin/dbx ./mozilla-bin core
dbx version 7.3.1 68542_Oct26 MR Oct 26 2000 17:50:34
Core from signal SIGBUS: Bus error
(dbx) where
>  0 JS_ArenaAllocate(pool = 0x10159cb8, nb = 16) ["/data/clink/atm/hankins/mozi
lla/js/src/jsarena.c":99, 0x4285ae8]
   1 js_alloc_temp_entry(priv = 0x10159c48, key = 0x10139080) ["/data/clink/atm/
hankins/mozilla/js/src/jsatom.c":715, 0x428d1b8]
   2 JS_HashTableRawAdd(ht = 0x10138618, hep = 0x101385d8, keyHash = 170, key = 
0x10139080, value = (nil)) ["/data/clink/atm/hankins/mozilla/js/src/jshash.c":24
2, 0x42be124]
   3 js_IndexAtom(cx = 0x10159c48, atom = 0x10139080, al = 0x7ffec2cc) ["/data/c
link/atm/hankins/mozilla/js/src/jsatom.c":777, 0x428d59c]
   4 js_EmitTree(cx = 0x10159c48, cg = 0x7ffec278, pn = 0x101384f8) ["/data/clin
k/atm/hankins/mozilla/js/src/jsemit.c":947, 0x42a7fc4]
   5 Statements(cx = 0x10159c48, ts = 0x10137e98, tc = 0x7ffec278) ["/data/clink
/atm/hankins/mozilla/js/src/jsparse.c":909, 0x43012fc]
   6 js_CompileTokenStream(cx = 0x10159c48, chain = 0x10156350, ts = 0x10137e98,
 cg = 0x7ffec278) ["/data/clink/atm/hankins/mozilla/js/src/jsparse.c":391, 0x42f
   7 CompileTokenStream(cx = 0x10159c48, obj = 0x10156350, ts = 0x10137e98, temp
Mark = 0x10159cc8, eofp = (nil)) ["/data/clink/atm/hankins/mozilla/js/src/jsapi.
c":2784, 0x4282988]
   8 JS_CompileUCScriptForPrincipals(cx = 0x10159c48, obj = 0x10156350, principa
ls = (nil), chars = 0x10136930, length = 2724, filename = (nil), lineno = 0) ["/
data/clink/atm/hankins/mozilla/js/src/jsapi.c":2863, 0x4282d34]
   9 JS_EvaluateUCScriptForPrincipals(cx = 0x10159c48, obj = 0x10156350, princip
als = (nil), chars = 0x10136930, length = 2724, filename = (nil), lineno = 0, rv
More (n if no)?  
 = 0x7ffec500) ["/data/clink/atm/hankins/mozilla/js/src/jsapi.c":3269, 0x4284108
   10 JS_EvaluateUCScript(cx = 0x10159c48, obj = 0x10156350, chars = 0x10136930,
 length = 2724, filename = (nil), lineno = 0, rval = 0x7ffec500) ["/data/clink/a
tm/hankins/mozilla/js/src/jsapi.c":3254, 0x4284088]
   11 JS_EvaluateScript(cx = 0x10159c48, obj = 0x10156350, bytes = 0x10135e80 = 
"// -*- Mode: Java; tab-width: 4; indent-tabs-mode: nil; c-basic-offset: 2 -*-\n
\n// The contents of this file are subject to the N\...", length = 2724, filenam
e = (nil), lineno = 0, rval = 0x7ffec500) ["/data/clink/atm/hankins/mozilla/js/s
rc/jsapi.c":3222, 0x4283efc]
   12 PREF_EvaluateConfigScript(js_buffer = 0x10135e80 = "// -*- Mode: Java; tab
-width: 4; indent-tabs-mode: nil; c-basic-offset: 2 -*-\n\n// The contents of th
is file are subject to the N\...", length = 2724, filename = (nil), bGlobalConte
xt = 0, bCallbacks = 1, skipFirstLine = 0) ["/data/clink/atm/hankins/mozilla/mod
ules/libpref/src/prefapi.c":511, 0x5499c3c]
   13 ::openPrefFileSpec(nsIFileSpec*,int,int,int,int)(aFilespec = 0x10135368, a
IsErrorFatal = 0, aVerifyHash = 0, aIsGlobalContext = 0, aSkipFirstLine = 0) ["/
data/clink/atm/hankins/mozilla/modules/libpref/src/nsPrefService.cpp":408, 0x54a
   14 ::openPrefFile(nsIFile*,int,int,int,int)(aFile = 0x101351d8, aIsErrorFatal
 = 0, aVerifyHash = 0, aIsGlobalContext = 0, aSkipFirstLine = 0) ["/data/clink/a
tm/hankins/mozilla/modules/libpref/src/nsPrefService.cpp":368, 0x54aee5c]
   15 ::pref_InitInitialObjects() ["/data/clink/atm/hankins/mozilla/modules/libp
ref/src/nsPrefService.cpp":601, 0x54b01cc]
More (n if no)?
   16 PREF_Init(filename = (nil)) ["/data/clink/atm/hankins/mozilla/modules/libp
ref/src/prefapi.c":338, 0x54995dc]
   17 nsPrefService::Init(void)(this = 0x10101088) ["/data/clink/atm/hankins/moz
illa/modules/libpref/src/nsPrefService.cpp":111, 0x54b3ed8]
   18 ::nsPrefServiceConstructor(nsISupports*,const nsID&,void**)(aOuter = (nil)
, aIID = 0x100349f0, aResult = 0x7ffeca3c) ["/data/clink/atm/hankins/mozilla/mod
ules/libpref/src/nsPrefsFactory.cpp":36, 0x54b7978]
   19 nsGenericFactory::CreateInstance(nsISupports*,const nsID&,void**)(this = 0
x10104788, aOuter = (nil), aIID = 0x100349f0, aResult = 0x7ffeca3c) ["/data/clin
k/atm/hankins/mozilla/xpcom/components/nsGenericFactory.cpp":55, 0x4117a40]
   20 nsComponentManagerImpl::CreateInstance(const nsID&,nsISupports*,const nsID
&,void**)(this = 0x10042b40, aClass = 0x7ffecaa0, aDelegate = (nil), aIID = 0x10
0349f0, aResult = 0x7ffeca3c) ["/data/clink/atm/hankins/mozilla/xpcom/components
/nsComponentManager.cpp":1205, 0x410c354]
   21 nsComponentManager::CreateInstance(const nsID&,nsISupports*,const nsID&,vo
id**)(aClass = 0x7ffecaa0, aDelegate = (nil), aIID = 0x100349f0, aResult = 0x7ff
eca3c) ["/data/clink/atm/hankins/mozilla/xpcom/components/nsRepository.cpp":81, 
   22 nsServiceManagerImpl::GetService(const nsID&,const nsID&,nsISupports**,nsI
ShutdownListener*)(this = 0x100420f8, aClass = 0x7ffecaa0, aIID = 0x100349f0, re
sult = 0x7ffecb80, shutdownListener = (nil)) ["/data/clink/atm/hankins/mozilla/x
pcom/components/nsServiceManager.cpp":344, 0x413064c]
   23 nsServiceManagerImpl::GetService(const char*,const nsID&,nsISupports**,nsI
ShutdownListener*)(this = 0x100420f8, aContractID = 0x546ff18 = "@mozilla.org/pr
More (n if no)?
, aIID = 0x100349f0, result = 0x7ffecb80, shutdownListener = (nil)) ["/data/clin
k/atm/hankins/mozilla/xpcom/components/nsServiceManager.cpp":491, 0x4130c44]
   24 nsServiceManager::GetService(const char*,const nsID&,nsISupports**,nsIShut
downListener*)(aContractID = 0x546ff18 = "@mozilla.org/preferences-service;1", a
IID = 0x100349f0, result = 0x7ffecb80, shutdownListener = (nil)) ["/data/clink/a
tm/hankins/mozilla/xpcom/components/nsServiceManager.cpp":604, 0x412d82c]
   25 nsGetServiceByContractID::operator()(const nsID&,void**) const(this = 0x7f
fecbe0, aIID = 0x100349f0, aInstancePtr = 0x7ffecb80) ["/data/clink/atm/hankins/
mozilla/xpcom/components/nsServiceManager.cpp":64, 0x412dfa8]
   26 nsCOMPtr_base::assign_from_helper(const nsCOMPtr_helper&,const nsID&)(this
 = 0x10159a58, helper = 0x7ffecbe0, iid = 0x100349f0) ["/data/clink/atm/hankins/
mozilla/xpcom/base/nsCOMPtr.cpp":65, 0x4077d1c]
   27 nsCOMPtr<nsIPrefService>::operator=(const nsCOMPtr_helper&)(this = 0x10159
a58, rhs = 0x7ffecbe0) ["/data/clink/atm/hankins/mozilla/dist/include/nsCOMPtr.h
":602, 0x5446fd0]
   28 nsScriptSecurityManager::InitPrefs(void)(this = 0x10159a40) ["/data/clink/
atm/hankins/mozilla/caps/src/nsScriptSecurityManager.cpp":2144, 0x5452b10]
   29 nsScriptSecurityManager::nsScriptSecurityManager(void)(this = 0x10159a40) 
["/data/clink/atm/hankins/mozilla/caps/src/nsScriptSecurityManager.cpp":1824, 0x
   30 nsScriptSecurityManager::GetScriptSecurityManager(void)() ["/data/clink/at
m/hankins/mozilla/caps/src/nsScriptSecurityManager.cpp":1842, 0x544e3f0]
   31 ::Construct_nsIScriptSecurityManager(nsISupports*,const nsID&,void**)(aOut
er = (nil), aIID = 0x5310090, aResult = 0x7ffececc) ["/data/clink/atm/hankins/mo
More (n if no)?
, 0x545b3d0]
   32 nsGenericFactory::CreateInstance(nsISupports*,const nsID&,void**)(this = 0
x10104728, aOuter = (nil), aIID = 0x5310090, aResult = 0x7ffececc) ["/data/clink
/atm/hankins/mozilla/xpcom/components/nsGenericFactory.cpp":55, 0x4117a40]
   33 nsComponentManagerImpl::CreateInstance(const nsID&,nsISupports*,const nsID
&,void**)(this = 0x10042b40, aClass = 0x7ffecf30, aDelegate = (nil), aIID = 0x53
10090, aResult = 0x7ffececc) ["/data/clink/atm/hankins/mozilla/xpcom/components/
nsComponentManager.cpp":1205, 0x410c354]
   34 nsComponentManager::CreateInstance(const nsID&,nsISupports*,const nsID&,vo
id**)(aClass = 0x7ffecf30, aDelegate = (nil), aIID = 0x5310090, aResult = 0x7ffe
cecc) ["/data/clink/atm/hankins/mozilla/xpcom/components/nsRepository.cpp":81, 0
   35 nsServiceManagerImpl::GetService(const nsID&,const nsID&,nsISupports**,nsI
ShutdownListener*)(this = 0x100420f8, aClass = 0x7ffecf30, aIID = 0x5310090, res
ult = 0x7ffed010, shutdownListener = (nil)) ["/data/clink/atm/hankins/mozilla/xp
com/components/nsServiceManager.cpp":344, 0x413064c]
   36 nsServiceManagerImpl::GetService(const char*,const nsID&,nsISupports**,nsI
ShutdownListener*)(this = 0x100420f8, aContractID = 0x530e178 = "@mozilla.org/sc
riptsecuritymanager;1", aIID = 0x5310090, result = 0x7ffed010, shutdownListener 
= (nil)) ["/data/clink/atm/hankins/mozilla/xpcom/components/nsServiceManager.cpp
":491, 0x4130c44]
   37 nsServiceManager::GetService(const char*,const nsID&,nsISupports**,nsIShut
downListener*)(aContractID = 0x530e178 = "@mozilla.org/scriptsecuritymanager;1",
 aIID = 0x5310090, result = 0x7ffed010, shutdownListener = (nil)) ["/data/clink/
More (n if no)?
, 0x412d82c]
   38 nsGetServiceByContractID::operator()(const nsID&,void**) const(this = 0x7f
fed088, aIID = 0x5310090, aInstancePtr = 0x7ffed010) ["/data/clink/atm/hankins/m
ozilla/xpcom/components/nsServiceManager.cpp":64, 0x412dfa8]
   39 nsCOMPtr_base::assign_from_helper(const nsCOMPtr_helper&,const nsID&)(this
 = 0x7ffed098, helper = 0x7ffed088, iid = 0x5310090) ["/data/clink/atm/hankins/m
ozilla/xpcom/base/nsCOMPtr.cpp":65, 0x4077d1c]
   40 nsCOMPtr<nsIScriptSecurityManager>::nsCOMPtr<nsIScriptSecurityManager>(con
st nsCOMPtr_helper&)(this = 0x7ffed098, helper = 0x7ffed088) ["/data/clink/atm/h
ankins/mozilla/dist/include/nsCOMPtr.h":552, 0x52f5be4]
   41 mozJSComponentLoader::ReallyInit(void)(this = 0x1015c670) ["/data/clink/at
m/hankins/mozilla/js/src/xpconnect/loader/mozJSComponentLoader.cpp":518, 0x52f15
   42 mozJSComponentLoader::ModuleForLocation(const char*,nsIFile*)(this = 0x101
5c670, registryLocation = 0x10104648 = "rel:nsFilePicker.js", component = 0x1015
c710) ["/data/clink/atm/hankins/mozilla/js/src/xpconnect/loader/mozJSComponentLo
ader.cpp":983, 0x52f32e0]
   43 mozJSComponentLoader::AttemptRegistration(nsIFile*,int)(this = 0x1015c670,
 component = 0x1015c710, deferred = 0) ["/data/clink/atm/hankins/mozilla/js/src/
xpconnect/loader/mozJSComponentLoader.cpp":834, 0x52f1a04]
   44 mozJSComponentLoader::AutoRegisterComponent(int,nsIFile*,int*)(this = 0x10
15c670, when = 0, component = 0x1015c710, registered = 0x7ffed4e8) ["/data/clink
/atm/hankins/mozilla/js/src/xpconnect/loader/mozJSComponentLoader.cpp":764, 0x52
More (n if no)?
   45 mozJSComponentLoader::RegisterComponentsInDir(int,nsIFile*)(this = 0x1015c
670, when = 0, dir = 0x101441e0) ["/data/clink/atm/hankins/mozilla/js/src/xpconn
ect/loader/mozJSComponentLoader.cpp":594, 0x52f24b0]
   46 mozJSComponentLoader::AutoRegisterComponents(int,nsIFile*)(this = 0x1015c6
70, when = 0, aDirectory = 0x101441e0) ["/data/clink/atm/hankins/mozilla/js/src/
xpconnect/loader/mozJSComponentLoader.cpp":550, 0x52f0904]
   47 ::AutoRegister_enumerate(nsHashKey*,void*,void*)(key = 0x10104608, aData =
 0x1015c670, aClosure = 0x7ffed930) ["/data/clink/atm/hankins/mozilla/xpcom/comp
onents/nsComponentManager.cpp":1928, 0x4107a08]
   48 ::_hashEnumerate(PLHashEntry*,int,void*)(he = 0x10110ac0, i = 1, arg = 0x7
ffed648) ["/data/clink/atm/hankins/mozilla/xpcom/ds/nsHashtable.cpp":191, 0x408c
   49 PL_HashTableEnumerateEntries(ht = 0x10046054, f = 0x408c700, arg = 0x7ffed
648) ["/data/clink/atm/hankins/mozilla/nsprpub/lib/ds/plhash.c":413, 0x43971c0]
   50 nsHashtable::Enumerate(int (*)(nsHashKey*,void*,void*),void*)(this = 0x100
46050, aEnumFunc = 0x4107940, closure = 0x7ffed930) ["/data/clink/atm/hankins/mo
zilla/xpcom/ds/nsHashtable.cpp":359, 0x408df44]
   51 nsSupportsHashtable::Enumerate(int (*)(nsHashKey*,void*,void*),void*)(this
 = 0x10046050, aEnumFunc = 0x4107940, closure = 0x7ffed930) ["/data/clink/atm/ha
nkins/mozilla/dist/include/nsHashtable.h":158, 0x410a694]
   52 nsComponentManagerImpl::AutoRegisterImpl(int,nsIFile*)(this = 0x10042b40, 
when = 0, inDirSpec = (nil)) ["/data/clink/atm/hankins/mozilla/xpcom/components/
nsComponentManager.cpp":2060, 0x4113240]
More (n if no)?
   53 nsComponentManagerImpl::AutoRegister(int,nsIFile*)(this = 0x10042b40, when
 = 0, inDirSpec = (nil)) ["/data/clink/atm/hankins/mozilla/xpcom/components/nsCo
mponentManager.cpp":1953, 0x410d910]
   54 nsComponentManager::AutoRegister(int,nsIFile*)(when = 0, directory = (nil)
) ["/data/clink/atm/hankins/mozilla/xpcom/components/nsRepository.cpp":200, 0x41
   55 ::NS_AutoregisterComponents(void)() ["/data/clink/atm/hankins/mozilla/xpfe
/bootstrap/nsSetupRegistry.cpp":92, 0x10019a14]
   56 ::NS_SetupRegistry_1(needAutoreg = 1) ["/data/clink/atm/hankins/mozilla/xp
fe/bootstrap/nsSetupRegistry.cpp":113, 0x10019bac]
   57 ::main1(int,char**,nsISupports*)(argc = 1, argv = 0x7ffedf14, nativeApp = 
(nil)) ["/data/clink/atm/hankins/mozilla/xpfe/bootstrap/nsAppRunner.cpp":1039, 0
   58 ::main(argc = 1, argv = 0x7ffedf14) ["/data/clink/atm/hankins/mozilla/xpfe
/bootstrap/nsAppRunner.cpp":1450, 0x10010004]
   59 __start() ["/xlv55/kudzu-apr12/work/irix/lib/libc/libc_n32_M4/csu/crt1text
.s":177, 0x10007b38]
(dbx) up
js_alloc_temp_entry: 715  JS_ARENA_ALLOCATE_TYPE(ale, JSAtomListElement, &cx->te
(dbx) l 710
   710  js_alloc_temp_entry(void *priv, const void *key)
   711  {
   712      JSContext *cx = priv;
   713      JSAtomListElement *ale;
>* 715      JS_ARENA_ALLOCATE_TYPE(ale, JSAtomListElement, &cx->tempPool);
   716      if (!ale) {
   717          JS_ReportOutOfMemory(cx);
   718          return NULL;
   719      }
(dbx) p ale
(dbx) p JSAtomListElement
Appropriate symbol not found for: JSAtomListElement
<symbol not found> 
(dbx) p cx
(dbx) p &cx
(dbx) p cx->tempPool
struct JSArenaPool {
    first = struct JSArena {
        next = 0x10137e88
        base = 269851848
        limit = 269851848
        avail = 269851848
    current = 0xdadadada
    arenasize = 1024
    mask = 7

Comment 1

17 years ago
This reminds me of bug 79562, also involving the MIPSpro compiler on IRIX. 
cc'ing Brendan, zeroJ@null.net for advice. Does this look like the same problem? 
Ever confirmed: true


17 years ago
Keywords: crash

Comment 2

17 years ago
CC -version
MIPSpro Compilers: Version 7.2.13m

Crash occurs consistently on startup.  I have compiled it only with default

Comment 3

17 years ago
Ryan ... could you indicate what configure flags you are using ... I have a 0.9
build I can test on.  Initially I would guess the problem is with your compiler
version ... we have only been using 7.3.1.?m.  We have every engr release of the
compiler on CDs so I should be able to help you out on this one ... however you
will do better with a gcc build at the moment until I get a fix for bug 79562. 
You can optimise gcc to -O6 with only occasional core dumps after extended use.

Comment 4

17 years ago
I have been using configure with no flags, just the basic ./configure; make

I'll try it with the 7.30 mips compilers.

Comment 5

17 years ago
Since you have a build using older compilers than we have tried, could I impose
on you to try only building the module js with MIPSpro 7.3.*, and revert back to
the older compiler to continue the build ... this way we can determine if using
MIPSpro 7.2 only fails in js, in which case I will ask my manager at SGI if I
can dedicate a bit of time to getting the js module to work using the older
compilers which many customers will still have installed.  

I dont know how easy this is ... if its too much trouble dont bother ... gcc
builds are faster atm anyhow.

Comment 6

17 years ago
I've just had a chat with Robert Low, the previous maintainer of the IRIX port,
and he pointed out bug 30427 which was solved with -OPT:wn_simplify=off . 
Perhaps you could give that a go.

Comment 7

17 years ago
I am not so sure that the keyword crash is appropriate, as this is occuring on 
an unsupported compiler version.

Comment 8

17 years ago
Of course, it won't let me build with the 7.30 compilers:

gmake[3]: Entering directory `/export/data/atm/hankins/mozilla/dom/src/base'
Building deps for nsJSEnvironment.cpp
CC -o nsJSEnvironment.o -c -DOSTYPE=\"IRIX6\" -DOSARCH=\"IRIX\"
-I../../../dist/include -I../../../dist/include
-I/hosts/clink/data/clink/atm/hankins/mozilla/dist/include/nspr         -KPIC  
-woff 3262 -n32  -DDEBUG -DDEBUG_hankins -DTRACING -g -I./../build 
-DJS_THREADSAFE=1  nsJSEnvironment.cpp
"nsJSEnvironment.cpp": Error: A goto outside a region cannot jump to a label
inside a region, 1 at line 369
gmake[3]: *** [nsJSEnvironment.o] Error 2
gmake[3]: Leaving directory `/export/data/atm/hankins/mozilla/dom/src/base'
gmake[2]: *** [install] Error 2
gmake[2]: Leaving directory `/export/data/atm/hankins/mozilla/dom/src'
gmake[1]: *** [install] Error 2
gmake[1]: Leaving directory `/export/data/atm/hankins/mozilla/dom'
gmake: *** [install] Error 2
[hankins@clink mozilla]$ CC -version
MIPSpro Compilers: Version 7.30

I suppose that might be a topic for a different bug...

Comment 9

17 years ago
I get the same dump when I compile everything with 7.30 compilers, after
commenting out those two lines that cause the compilation to fail.

Comment 10

17 years ago
Our approach to date has been to only use/support the latest engr release of 
MIPSpro ... as Mozilla has consistently created new MIPSpro optimisation bugs.  
I have done one workaround where it was simple ... and it looks like one is 
possible for bug 79562, which looks too similar to this one, as 
JS_ARENA_ALLOCATE_TYPE is #defined in js/src/jsarena.h to use 

Comment 11

17 years ago
-OPT:wn_simplify=off fixes the problem, eliminating the segfault.  Can that be
added to the makefiles for the MIPSpro compilers (if gcc isn't found on an IRIX
box, use that option?)
http://support.sgi.com/colls/patches/tools/relstream/index.html is the link
given by var@sgi.com, in the bug 30427 that this report duplicates, as the place
to go to upgrade your busted MIPSPro compiler to a fixed version.


*** This bug has been marked as a duplicate of 30427 ***
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Ahem. Caffeine-enabled, I've read this bug now, and related bugs, and want to
apologize for mad dup'ing. If this bug should be reopened, please do so and say
what fix someone responsible for the JS engine needs to make -- or reassign to a
better owner. Sorry again.


Comment 14

17 years ago
Reassigning to build config, since this should really be fixed there.

It would be nice to check for old compilers, and not gcc, and IRIX, and if we
have all of those, to enable that particular compiler flag.

Also going to drop priority.
Severity: blocker → normal
Component: Javascript Engine → Build Config
Resolution: DUPLICATE → ---

Comment 15

17 years ago
Setting default owner and QA -
Assignee: rogerl → cls
QA Contact: pschwartau → granrose

Comment 16

17 years ago
Ok, so here's the interesting part....cement, the Irix tinderbox on the
SeaMonkey-Ports page, is using MIPSPro Version and appears to have no
problems starting up or running the tinderbox tests.  The Irix nightlies are
also created on that box.  So we have conflicting sets of data here.  

Ryan, can you run the nightlies builds where your custom builds fail?  Also, can
you provide the complete set of configure options and commands that you used to
create your custom builds?

Comment 17

17 years ago
Nightly builds work just fine for me.  I'm typing this using 2001062821.

To compile the source releases that crash, I just do a ./configure, then a gmake.

I've used, and 7.30 release compilers, and they both seem to cause this

I was under the impression that the nightly builds were gcc builds.

Comment 18

17 years ago
Nope, the nightly builds are definitely using cc & CC to build.  Do you see the
crash in your custom build if you use ./configure --disable-debug
--enable-optimize ? 

If you are going to use the 7.3 series of the compiler, I definitely recommend
using the latest version of that series (

Comment 19

17 years ago
./configure  --disable-debug --enable-optimize on the 7.30 compilers crashes. 
I'll try with the new compilers when I get a chance.

Comment 20

17 years ago
$ cc -version
MIPSpro Compilers: Version
$ CC -version
MIPSpro Compilers: Version

Crashes on startup just like the others.

Comment 21

17 years ago
I'm not convinced that this is a general Irix compiler problem since so far, no
one has been able to reproduce the problem.   I can't find any reference to
'wn_simplify' in the opt manpage.  What exactly does -OPT:wn_simplify=off do?

Priority: -- → P4
Target Milestone: --- → Future

Comment 22

17 years ago
-OPT:wn_simply=OFF turns off the simplifier, which can be seen to cause the 
problem in bug 30427.  I can only reproduce these js problems with --disable-
debug ... does cement --disable-debug?

Before I make changes to any Makefile.in's ... can you attach the diff of the 
modifications you made to remove the goto ... and verify that it was MIPSpro 
7.30 with -OPT:wn_simplify=off which builds and runs.

Comment 23

17 years ago
No, the cement tinderbox build does not use --disable-debug but the Irix nightly
builds that come from cement do use --disable-debug . I'll move cement to doing
an optimized build to see if it make a difference.

Comment 24

17 years ago
Sounds good.  Do the nightly builds also undergo tinderbox tests before they 
are deemed fit for the public?

Comment 25

17 years ago
Nope.  They are just built and packaged.

Comment 26

17 years ago
Sorry about the delay; I have been away and very busy.

Anyway, it was definitely MIPSPro 7.30 with -OPT:wn_simplify=off.

To remove that goto, I just commented out the two offending lines as a quick
fix, assuming that it was an error condition that wouldn't occur normally. 
Obviously it needs a better fix than that.

Comment 27

17 years ago
This works fine in 0.9.3, with the same compilers and everything.  Suggest this
bug be closed.

Comment 28

17 years ago
resolving WFM per reporter's comments.
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 29

17 years ago
verifying, same.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.