If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[email] CSS shown at top of email

RESOLVED DUPLICATE of bug 864867

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 864867
5 years ago
5 years ago

People

(Reporter: overholt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 743248 [details]
comparative screenshots

See the attached screenshot comparing the same email displayed in K-9 mail on Android, Thunderbird on Linux, and the gaia email client.  It sort of looks like the CSS in the email is being displayed above the content.

I'll send Andrew the message source privately.
(Reporter)

Comment 1

5 years ago
Oh, and I should mention this is on an unagi with a locally-built v1.0.1 (gecko fd004d7126, gaia cf2d4136f).
This is bug 864867; you are seeing CSS in the message because when we fetch the first 4k, that only gets us partway through the CSS.  when we fetch the rest of the body and forget about the first 4k, the sanitizer doesn't know that it's in CSS and so treats it like text.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Summary: CSS shown at top of email → [email] CSS shown at top of email
Duplicate of bug: 864867
You need to log in before you can comment on or make changes to this bug.