Browser fails to open after Linux Installation

RESOLVED INVALID

Status

SeaMonkey
General
P2
blocker
RESOLVED INVALID
17 years ago
13 years ago

People

(Reporter: Peter Jeziorek, Assigned: asa)

Tracking

({smoketest})

Trunk
mozilla0.9.2
x86
Linux
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Netscape 6.0 Linux 2001-06-19-08-trunk Build
The browser fails to open after linux installation, or when trying to open the
browser manually.

The error I receive is:
"
...
moz_debug=0
moz_debugger=
/home/smoketest/netscape/mozilla-bin: error in loading shared libraries:
libnullplugin.so: cannot open shared object file: No such file or directory
"

To Reproduce:
1. Go to the above link and download the 2001-06-19-08-trunk Linux build.
2. Install the build
3. At the end of installation you will see the error.

Comment 1

17 years ago
adding smoketest to keywords so it shows up on the radar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: smoketest
Priority: -- → P2
Summary: Smoketest Blocker: Browser fails to open after Linux Installation → Browser fails to open after Linux Installation
Target Milestone: --- → mozilla0.9.2

Comment 2

17 years ago
ccing installer folks on the off chance this is an installer problem although I
suspect packaging since apparently the tarball works.

Comment 3

17 years ago
Checked the browser.xpi for libnullplugin.so.  It appears to be packaged fine.  

Peter,
Please attach your install.log found next to the browser binary to this bug. 
Thanks.
(Reporter)

Comment 4

17 years ago
Created attachment 39168 [details]
Install Log

Comment 5

17 years ago
This has already been fixed.  Re-pull xpfe/boostrap/Makefile.in and make -C
xpfe/bootstrap 

Comment 6

17 years ago
cls, I noticed your checkin at 10, but it didn't seem related to our Linux 
blocker at all. Can I respin with _just that fix?

Comment 7

17 years ago
cc'ing cls since he probably didn't see my last comment.
Chris, please inform both the shriff and the build guy of the day about your 
checkings during tree closure.

Comment 8

17 years ago
Sorry, I actually didn't realize that was the problem until after dbaron asked
me about shrike's orange streak post checkin.  Yes, all you need to rebuild is
that single directory. 

Comment 9

17 years ago
mrking fixed for cls
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
*** Bug 86562 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
Reopening this.  I cannot open the browser after installing Linux
2001-06-21-11-trunk or 2001-06-21-15-trunk builds.  Right after the install
completes, nothing happens.  When I then try to start manually, I get the
Activation screen, but I can't get past it.  If I cancel Activation, nothing
further happens.  If I go through the Activation procedure, nothing further
happens; if I then try starting the browser again, I get the Activation prompt
again, with the choice of starting with the account I just created.  But again,
nothing happens after clicking OK.



Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

17 years ago
Note that I tested on Linux 7.1 Ja.
might you be encountering bug 87119, which was moved into bugscape as
http://bugscape.mcom.com/show_bug.cgi?id=6758 since it's commercial-only? [due
to the activation stuff.]

a possible workaround for you [i was able to use 2001.06.21.11 linux comm bits,
installer stub installation]: i just used the command-line to create [netscape
-CreateProfile <profile-name>] and launch [netscape -P <profile-name>] profiles.

Comment 14

17 years ago
Correction:  I tested on Redhat 7.0 Ja, not 7.1.  I will investigate per
sairuh's comments and update as appropriate.

Comment 15

17 years ago
reclosing since this is a netscape bug dealing with activation, it should not be
in bugzilla.  Please put any comments in the bugscape bug.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.