[PP] Linux - if form contains multiple identical options...

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: cpratt, Assigned: Ramiro Estrugo)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Build ID: 1999062208
Platform: RH Linux 5.2

To reproduce: Load the above URL. Click once to drop down the menu. Now, move
the mouse slowly down the menu. There are two OPTIONs that occur several times:
Yahoo! and ------------. When you pass the cursor over the first instance, it is
(properly) selected. When the mouse has gone down enough to be over a subsequent
instance, the first instance is highlighted and a black rectangle is drawn
around the subsequent instance. Expected behavior is that only the subsequent
instance is highlighted.

I was not able to reproduce this on Win32 and Mac OS 8.6.

Updated

19 years ago
Assignee: trudelle → karnaze
Component: XP Toolkit/Widgets → HTML Form Controls

Comment 1

19 years ago
This is not a menu, its an HTML Select form control. Changing component to HTML
Form Controls, reassigning to karnaze.
CPratt: please take note!

Updated

19 years ago
Whiteboard: [TESTCASE]

Comment 2

19 years ago
Attaching a simple testcase for the benefit of those not on the NS intranet.
Another observation -- behavior is case-insensitive, too.
(tested with Linux/M7)

Comment 3

19 years ago
Created attachment 640 [details]
testcase
(Reporter)

Comment 4

19 years ago
Created attachment 641 [details]
The test case originally referred to in this bug

Updated

19 years ago
Assignee: karnaze → kmcclusk

Comment 5

19 years ago
Reassigning to Kevin.

Updated

19 years ago
Assignee: kmcclusk → ramiro
Works correctly with gfx-rendered select. Also confirmed that it works on WIN32
with native widgets.

Ramiro I'm re-assigning to you, but this is probably not worth fixing, since
gfx-rendered select's will be enabled shortly.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

18 years ago
yeah, works fine with gfx widgets on linux.

marking worksforme.

Comment 8

18 years ago
Updating QA contact.
QA Contact: phillip → bsharma

Comment 9

17 years ago
Worksforme:
Platform: PC
OS: Red Hat 6.2 (Linux 2.2.14)
Mozilla: 2000101212 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.