[unagi][tara][weekly build 13.04.17]monkey test crash in mozilla::dom::ContentChild::ProcessingError

RESOLVED DUPLICATE of bug 867025

Status

Firefox OS
General
--
critical
RESOLVED DUPLICATE of bug 867025
5 years ago
5 years ago

People

(Reporter: James Zhang (Spreadtrum), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Hi Justin and bent,

   Please find 'ABORT' log in unagi/tara crash report, in the bugreport file.

   If exist 'ABORT' log, also exist 'camera close' log in context. Maybe camera close cause this abort?

unagi log
04-25 14:51:35.850   117  5893 E CAM_FD  : cam_conf: CAMERA_EXIT
04-25 14:51:35.850   117   117 I QualcommCameraHardware: release X: mCameraRunning = 0, mFrameThreadRunning = 0
04-25 14:51:35.850   117   117 I QualcommCameraHardware: mVideoThreadRunning = 0, mSnapshotThreadRunning = 0, mJpegThreadRunning = 0
04-25 14:51:35.850   117   117 I QualcommCameraHardware: camframe_timeout_flag = 0, mAutoFocusThreadRunning = 0
04-25 14:51:35.850   117   117 E QualcommCamera: Qint android::set_preview_window(camera_device*, preview_stream_ops*): E window = 0x0
04-25 14:51:35.850   117   117 E QualcommCameraHardware: : set_preview_window
04-25 14:51:35.850   117   117 V QualcommCameraHardware:  setPreviewWindow: E 
04-25 14:51:35.850   117   117 W QualcommCameraHardware:  Setting NULL preview window 
04-25 14:51:35.850   117   117 E QualcommCameraHardware: Set preview window:: 
04-25 14:51:35.850   117   117 V QualcommCameraHardware:  setPreviewWindow : X 
04-25 14:51:35.850   117   117 E QualcommCamera: Qint android::close_camera_device(hw_device_t*): device =0x1cefc98 E
04-25 14:51:35.850   117   117 I QualcommCamera: void android::close_Hal_obj(camera_device*): E
04-25 14:51:35.850   117   117 I QualcommCamera: void android::close_Hal_obj(camera_device*): clear hw
04-25 14:51:35.850   117   117 I QualcommCameraHardware: ~QualcommCameraHardware E
04-25 14:51:35.850   117   117 V QualcommCameraHardware: ~MMCameraDL: E
04-25 14:51:35.860   117  5901 V QualcommCameraHardware: runFrameThread X
04-25 14:51:35.880   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x44000000 size:233472 fd:210
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x44151000 size:233472 fd:242
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x44500000 size:233472 fd:247
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x44665000 size:233472 fd:258
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x44a00000 size:233472 fd:261
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x44ba7000 size:233472 fd:264
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x45013000 size:233472 fd:267
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x451a1000 size:233472 fd:270
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem_adsp: Freeing buffer base:0x45700000 size:233472 fd:274
04-25 14:51:35.900   111   252 D memalloc: /dev/pmem: Freeing buffer base:0x4b40a000 size:614400 offset:4628480 fd:180
04-25 14:51:35.910  5877  5877 D memalloc: /dev/pmem: Unmapping buffer base:0x46882000 size:5242880 offset:4628480
04-25 14:51:35.910  5877  5877 D memalloc: /dev/pmem: Unmapping buffer base:0x44400000 size:5324800 offset:5242880
04-25 14:51:35.920  5877  5877 D memalloc: /dev/pmem: Unmapping buffer base:0x45128000 size:8343552 offset:8335360
04-25 14:51:35.930   111   252 D memalloc: /dev/pmem: Freeing buffer base:0x4b4a0000 size:81920 offset:5242880 fd:183
04-25 14:51:35.930  5877  5877 I Gecko   : 
04-25 14:51:35.930  5877  5877 I Gecko   : ###!!! [Child][AsyncChannel] Error: Route error: message sent to unknown actor ID
04-25 14:51:35.930  5877  5877 I Gecko   : 
04-25 14:51:35.940  5877  5877 I Gecko   : [Child 5877] ###!!! ABORT: aborting because of fatal error: file /home/apuser/unagi_weekly_build/B2G/gecko/dom/ipc/ContentChild.cpp, line 1020
04-25 14:51:35.940  5877  5877 E Gecko   : mozalloc_abort: [Child 5877] ###!!! ABORT: aborting because of fatal error: file /home/apuser/unagi_weekly_build/B2G/gecko/dom/ipc/ContentChild.cpp, line 1020
04-25 14:51:35.960   111   252 D memalloc: /dev/pmem: Freeing buffer base:0x4b632000 size:614400 offset:6889472 fd:279
04-25 14:51:35.970   111   252 D memalloc: /dev/pmem: Freeing buffer base:0x4b4b4000 size:81920 offset:5324800 fd:197
04-25 14:51:36.100   117   117 V QualcommCameraHardware: closed MM Camera DL 
04-25 14:51:36.100   117   117 V QualcommCameraHardware: ~MMCameraDL: X
04-25 14:51:36.100   117   117 I QualcommCameraHardware: ~QualcommCameraHardware X
04-25 14:51:36.100   117   117 I QualcommCamera: void android::close_Hal_obj(camera_device*): X

tara log
04-25 23:13:46.327    81 25111 I CameraService: Destroying camera 0
04-25 23:13:46.327    81 25111 I SprdCameraHardware: int android::HAL_camera_device_close(hw_device_t*)
04-25 23:13:46.327    81 25111 V SprdCameraHardware: ~SprdCameraHardware E
04-25 23:13:46.327    81 25111 V SprdCameraHardware: ~SprdCameraHardware X
04-25 23:13:46.327    81 25111 D CameraService: CameraService::removeClient E (pid 10075)
04-25 23:13:46.327    81 25111 D CameraService: removeClient: clear camera 0
04-25 23:13:46.327    81 25111 D CameraService: CameraService::removeClient X (pid 10075)
04-25 23:13:46.327    81 25111 E CameraService: disconnect X (pid 10075)
04-25 23:13:46.337    81  3941 D CameraService: Client::~Client E (pid 81, this 0x1477648)
04-25 23:13:46.337    81  3941 E CameraService: disconnect E (pid 81)
04-25 23:13:46.337    81  3941 D CameraService: CameraService::releaseSound ref=1
04-25 23:13:46.337    81  3941 I MediaPlayerService: disconnect(47) from pid 81
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4 a
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4 b
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4 c
04-25 23:13:46.337    81 10492 I OMXCodec: [OMX.google.vorbis.decoder] Now Idle.  mState(0), mState
04-25 23:13:46.337    81 10492 I OMXCodec: [OMX.google.vorbis.decoder] Now Loaded.
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=1 d
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=1 e
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stopped in state 1
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] ~OMXCodec in state 
04-25 23:13:46.337    81  3941 I AwesomePlayer: --mSystemTimeSourceForSync reset ok
04-25 23:13:46.337    81  3941 I AwesomePlayer: --mSystemTimeSourceForSync reset ok
04-25 23:13:46.337    81  3941 I AwesomePlayer: --mSystemTimeSourceForSync reset ok
04-25 23:13:46.337    81  3941 I MediaPlayerService: Client(47) destructor pid = 81
04-25 23:13:46.337    81  3941 I MediaPlayerService: disconnect(47) from pid 81
04-25 23:13:46.337    81  3941 V AudioFlinger: releasing 287 from 81
04-25 23:13:46.337    81  3941 W AudioFlinger: session id 287 not found for pid 81
04-25 23:13:46.337    81  3941 I MediaPlayerService: disconnect(48) from pid 81
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4 a
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4 b
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=4 c
04-25 23:13:46.337    81 10495 I OMXCodec: [OMX.google.vorbis.decoder] Now Idle.  mState(0), mState
04-25 23:13:46.337    81 10495 I OMXCodec: [OMX.google.vorbis.decoder] Now Loaded.
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=1 d
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stop mState=1 e
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] stopped in state 1
04-25 23:13:46.337    81  3941 I OMXCodec: [OMX.google.vorbis.decoder] ~OMXCodec in state 
04-25 23:13:46.337    81  3941 I AwesomePlayer: --mSystemTimeSourceForSync reset ok
04-25 23:13:46.337    81  3941 I AwesomePlayer: --mSystemTimeSourceForSync reset ok
04-25 23:13:46.337    81  3941 I AwesomePlayer: --mSystemTimeSourceForSync reset ok
04-25 23:13:46.337    81  3941 I MediaPlayerService: Client(48) destructor pid = 81
04-25 23:13:46.337    81  3941 I MediaPlayerService: disconnect(48) from pid 81
04-25 23:13:46.337    81  3941 V AudioFlinger: releasing 288 from 81
04-25 23:13:46.337    81  3941 W AudioFlinger: session id 288 not found for pid 81
04-25 23:13:46.337    81  3941 D CameraService: Client::~Client X (pid 81, this 0x1477648)
04-25 23:13:46.397 10075 10075 I Gecko   : 
04-25 23:13:46.397 10075 10075 I Gecko   : ###!!! [Child][AsyncChannel] Error: Route error: message sent to unknown actor ID
04-25 23:13:46.397 10075 10075 I Gecko   : 
04-25 23:13:46.397 10075 10075 I Gecko   : [Child 10075] ###!!! ABORT: aborting because of fatal error: file /home/apuser/MocorHTML5/b2g_latest/B2G/gecko/dom/ipc/ContentChild.cpp, line 1020
04-25 23:13:46.397 10075 10075 E Gecko   : mozalloc_abort: [Child 10075] ###!!! ABORT: aborting because of fatal error: file /home/apuser/MocorHTML5/b2g_latest/B2G/gecko/dom/ipc/ContentChild.cpp, line 1020

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 867025
You need to log in before you can comment on or make changes to this bug.