Mothers Day - (Due May 6th)

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jacob, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
Mother's Day is coming.

I started drafting something up - https://thimble.webmaker.org/p/lql1/

https://thimble.webmaker.org/p/lql1/edit

Ignore the instructions in the comments, those will be written later. Also there's text at the bottom that I couldn't change to white, so highlight it so you can read it :P

Please give hacks and feedback
(Reporter)

Updated

5 years ago
Duplicate of this bug: 867026
(In reply to Jacob from comment #0)
> Mother's Day is coming.
> 
> I started drafting something up - https://thimble.webmaker.org/p/lql1/
> 
> https://thimble.webmaker.org/p/lql1/edit
> 
> Ignore the instructions in the comments, those will be written later. Also
> there's text at the bottom that I couldn't change to white, so highlight it
> so you can read it :P
> 
> Please give hacks and feedback

Hey Jacob, I like the photo much more than the last one!

One suggestion would be to put the text below in its own frame/container so it looks less like an add-on and more like a part of the template. You could style it the same as the image above, only have text in the middle instead of the photograph...

What would the suggestion for the text be? Something about "your favourite memory of your Mom" or something more explicit ala 6-words format?
(Reporter)

Comment 3

5 years ago
Spent a little time trying to make a second box container for message text on the lower half and kept messing other parts of the card :-/ 

Sorry, my CSS is not quite there yet to write from scratch.

Any chance Kat or Paula, you could make a quick pass at the styling and I can work on drafting the copy for webmaker.org?

Also, if you have ideas for a better background image, I'm open to that too
jacob, i love that you're digging into css skillz.

For me I'm seeing that the text doesn't have a background, which makes it hard to read.

One thing - I'm sure :k88hudson wouldn't mind giving a few pointers if you had specific questions.  If you knew the effect you wanted to achieve but wanted some css tips, don't feel it's disruptive to ask.

I like the broad appeal of the concept - are you going to try for a few?  Something on the silly side might be nice, too :)
(Reporter)

Comment 5

5 years ago
So we've got a draft of the webmaker project here: https://make-dev.mozillalabs.com/en-US/projects/make-mom-proud/

And I've updated the Thimble project to include comments with instructions specific to this project - https://thimble.webmaker.org/p/lqs2/edit

All we need now is some styling for the bottom message.

:Paula said she'd be willing to take a crack at it! I'll be waking up around 2pm London time to check in and see where we're at.

It also sounds like I'll also need to record a screencast before the Monday May 6th All-Hands as indicated in #866688 so it'd be good to get that out of the way tomorrow (Friday) as well.

Thanks!

Comment 6

5 years ago
I have tried twice today to get to this but both times I haven't been able to load the editable version in thimble (thimble toolbar loads but both editing panes do not - loading swirl) . I have noticed this happening more and more lately. I will try again over the weekend.
as noted by Paula, there's currently a serious problem with Chrome browsers, it seems - Thimble projects won't load, and Popcorn vids don't load with sound. Maybe this is old news though - know of a bug somewhere, Jacob? ;)

Comment 8

5 years ago
I just tested this locally, and it seems to work fine for me, but please file a bug with this issue so we can investigate

Comment 9

5 years ago
Checking in: our window with @Firefox channels is almost closed. Do we have a status update?
@kat - we're not seeing those chrome problems.  If you guys can give us specific steps to reproduce, we'll look into this.

@rebeccah - lets circle back shortly. This Thimble project is not ready for production, so we may not be able to meet this.
Rebeccah - can you clarify when @firefox channel deadlines are?

Comment 12

5 years ago
@firefox requires a minimum of two weeks to program a finished project into channel. They asked us mid-March for a Mother's Day project similar to the Love Bomb generator. 

We were hoping to show them something Wed/Thurs, but it looks like there's been some technical delays. 

I'm going to let @firefox know we won't have anything - shame because they have driven the two biggest project related site spikes we've had. (10.5k hits vs the average 300-1k)

I'd be happy to have this project to promote on our own channels however, for Monday/Tuesday. Our metrics show that we need about a week ahead of a date-specific project in order for us to give it any real chance to hit audience.

Comment 13

5 years ago
Hello

Here is a super simple Mother's Day project - https://thimble.webmaker.org/p/lrb9/
Here is a slightly more complex Mother's Day project - https://thimble.webmaker.org/p/lrbi/

Thanks everyone
(Reporter)

Comment 14

5 years ago
I also made an attempt to better style my original one. Here's two more options:

https://thimble.webmaker.org/p/lrko/
https://thimble.webmaker.org/p/lrkp/
(Reporter)

Comment 15

5 years ago
I've updated the projects to include some copy edits that better explain how to get an image URL from Flickr, and also how to credit the photo. I also consolidated the h1, h2, and h3 CSS properties together, since they were listed twice.

https://thimble.webmaker.org/p/lrxw
https://thimble.webmaker.org/p/lrn0/

In addition, I made a third one to show at the all hands presentation, which is for the geek crowd to explain to their mom what it is they do:

https://thimble.webmaker.org/p/lrn0/

We still may want to consider adding a semi-opaque box around the text like I attempted to do above in comment #14 in case people pick a background that isn't as dark or has a lot of business on it.

One question: do we have safeguards in place to make the background safe for different size images? Basically make it so it doesn't repeat in an ugly way if the picture is too small, or that it shrinks to an appropriate size if the picture is too large.
(Reporter)

Comment 16

5 years ago
@Paula - do you think we're safe to take this live for the Tue Webmaker call?

https://make-dev.mozillalabs.com/en-US/projects/make-mom-proud/
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Component: Projects → General
Product: Webmaker → Webmaker
You need to log in before you can comment on or make changes to this bug.