landscape or landscape-secondary orientation locked apps render portrait in the task manager, which breaks the view of the app

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Followup on bug 861846. We fixed the bug for the landscape-primary use case, but we didn't fix it for the landscape or landscape-secondary use cases. As a result, gaming apps will still render badly that use either of those orientations (e.g. Poppit uses landscape, so it will still render badly).
(Reporter)

Updated

5 years ago
Blocks: 861846
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
Created attachment 743619 [details]
Patch v1
Attachment #743619 - Flags: review?(21)
(Assignee)

Comment 2

5 years ago
When we will have the r+ and tef+, I gonna implement it for v1.0.1 because right now to uplift this one is impossible.

Updated

5 years ago
blocking-b2g: tef? → tef+
(Assignee)

Comment 3

5 years ago
Comment on attachment 743619 [details]
Patch v1

Hi, Alive, do you want to take a look to this tef+ bug? It is very simple. Thanks a lot my friend!
Attachment #743619 - Flags: review?(21) → review?(alive)
Comment on attachment 743619 [details]
Patch v1

The logic makes sense, r=me.
Attachment #743619 - Flags: review?(alive) → review+
(Assignee)

Comment 5

5 years ago
Perfect!! I am going to review lint issues, I have some errors. Thanks Alive

----- FILE  :  /home/travis/build/mozilla-b2g/gaia/apps/system/test/unit/cards_view_test.js -----
Line 181, E:0110: Line too long (81 characters).
Line 187, E:0110: Line too long (81 characters).
(Assignee)

Comment 6

5 years ago
Waiting for Travis results again...
(Assignee)

Comment 7

5 years ago
https://github.com/mozilla-b2g/gaia/commit/1683b36b1e5b488a9b0e95679141a0019a4e37fb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
I was not able to uplift this bug to v1-train and v1.0.1.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train and v1.0.1, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 1683b36b1e5b488a9b0e95679141a0019a4e37fb
  <RESOLVE MERGE CONFLICTS>
  git commit
  git checkout v1.0.1
  git cherry-pick -x $(git log -n1 v1-train --pretty=%H)
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
(Assignee)

Comment 9

5 years ago
I was trying to resolve the conflicts but currently it is impossible. The patch without tests is very easy to merge but the problem is due to the unit test. They are based on mockups implemented in other bugs like bug 847241 non uplifted. The first alternative is to resolve conflicts without unit tests or... add more mockup files that don't belong to my bug. What can we do here? Thanks
Flags: needinfo?(jhford)
Uplifting this without the tests that depend on a feature that'll not be uplifted seems logical to me, but I'd like to get confirmation that from tef+'er.

Daniel, what are your thoughts on the risk of uplifting this without these tests?
Flags: needinfo?(jhford) → needinfo?(dcoloma)
(In reply to John Ford [:jhford] -- If you expect a reply from me, use needsinfo? instead of CC from comment #10)
> Uplifting this without the tests that depend on a feature that'll not be
> uplifted seems logical to me, but I'd like to get confirmation that from
> tef+'er.
> 
> Daniel, what are your thoughts on the risk of uplifting this without these
> tests?

It seems also logical to me not including the tests in the uplift if this is the easier solution.
Flags: needinfo?(dcoloma)
(In reply to Daniel Coloma:dcoloma from comment #11)
> (In reply to John Ford [:jhford] -- If you expect a reply from me, use
> needsinfo? instead of CC from comment #10)
> > Uplifting this without the tests that depend on a feature that'll not be
> > uplifted seems logical to me, but I'd like to get confirmation that from
> > tef+'er.
> > 
> > Daniel, what are your thoughts on the risk of uplifting this without these
> > tests?
> 
> It seems also logical to me not including the tests in the uplift if this is
> the easier solution.

Sounds OK to me too
(Assignee)

Comment 13

5 years ago
v1-train

abebb008a5da85a31ed935a07542d419047e83fc
status-b2g18: affected → fixed
(Assignee)

Comment 14

5 years ago
v1.0.1

9358da03e0437b328ac73bd39174b4e89441cabd
status-b2g18-v1.0.1: affected → fixed
(Reporter)

Comment 15

5 years ago
Verified with a landscape, landscape-primary, and landscape-secondary locked app. 5/15 1.01 build.
status-b2g18-v1.0.1: fixed → verified
Keywords: verifyme

Comment 16

5 years ago
Can you please provide steps to verify this fix - as we will blackbox test from the UI?
(Reporter)

Comment 17

5 years ago
(In reply to Deepa Subramanian from comment #16)
> Can you please provide steps to verify this fix - as we will blackbox test
> from the UI?

I already verified this fix on 1.01 in full.

For 1.1, you would need to install the Poppit app from https://marketplace.firefox.com/app/poppit/, open the task manager, and verify the orientation of the app in the card view is in landscape.
(Reporter)

Comment 18

5 years ago
(In reply to Jason Smith [:jsmith] from comment #17)
> (In reply to Deepa Subramanian from comment #16)
> > Can you please provide steps to verify this fix - as we will blackbox test
> > from the UI?
> 
> I already verified this fix on 1.01 in full.
> 
> For 1.1, you would need to install the Poppit app from
> https://marketplace.firefox.com/app/poppit/, open the task manager, and
> verify the orientation of the app in the card view is in landscape.

Note - you need to launch the app after install too.

Comment 19

5 years ago
App is seen on the homescreen (greyedout. When tried to launch prompted with restart download msg. Tapping on download gave "Poppit download stopped" msg on the home screen bottom.

Tested on Unagi
Build Id: 201300515070208
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia   0ddb515f15cbc6b74fc2742b7599d6ae74c6413f

Also, Unable to open https://marketplace.firefox.com/app/poppit/ 
Got a msg as "server not found".
Leo Build ID: 20130515070208  
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/d06cfe7d67c2
Gaia   0ddb515f15cbc6b74fc2742b7599d6ae74c6413f
(Reporter)

Comment 20

5 years ago
That's a known that the app can't be downloaded. Fix will be pushed on Thursday.
You need to log in before you can comment on or make changes to this bug.