Camera names should percolate upwards to the UI

RESOLVED DUPLICATE of bug 862377

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 862377
6 years ago
6 years ago

People

(Reporter: gcp, Assigned: gcp)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia][android-gum+][blocking-gum-])

Currently, the WebRTC UI for Android does not receive the camera names from the underlying C++ code. This makes it impossible to make the UI distiction for front/back cameras, for example.

Audio might need this too in the Bluetooth case.
Where in the code flow are the names not passed forward? Is this something we fix in the UI or in the platform (and then the UI)?
Whiteboard: [getUserMedia][android-gum+]
Whiteboard: [getUserMedia][android-gum+] → [getUserMedia][android-gum+][blocking-gum-]
This needs to be fixed in platform first, IIRC.
Whiteboard: [getUserMedia][android-gum+][blocking-gum-] → [getUserMedia][android-gum+]
Assignee: nobody → gpascutto
Whiteboard: [getUserMedia][android-gum+] → [getUserMedia][android-gum+][blocking-gum-]
This is being handled as part of 862377.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862377
No longer blocks: android-webrtc
You need to log in before you can comment on or make changes to this bug.