Refresh the page with Data Sharing Off and for a short duration the Data Sharing is On

RESOLVED DUPLICATE of bug 1209549

Status

Firefox Health Report
Web: Health Report
--
minor
RESOLVED DUPLICATE of bug 1209549
5 years ago
2 years ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Reproducible on the latest Beta (BuildID: 20130425162858):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:21.0) Gecko/20100101 Firefox/21.0
Reproducible on the latest Aurora (BuildID: 20130430004015):
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:22.0) Gecko/20100101 Firefox/22.0
Reproducible on the latest Nightly (BuildID: 20130430030941): 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:23.0) Gecko/20100101 Firefox/23.0

Steps to reproduce:
1. Start Firefox and go to about:healthreport. 
2. Set Data Sharing to OFF
3. Refresh the page.

Expected results: Data Sharing has the same option set previously.

Actual results: For a short time Data Sharing changes it`s value and then it comes back to the one previously selected.

Notes:
1. The issue reproduces on Windows XP x32 and Ubuntu 12.04 x32 as well.
2. There is no change in about:config on datareporting.healthreport.uploadEnabled so it does not change the functionality it`s only a UI issue.
3. I`ve attached a screencast showing the issue:
http://www.screencast.com/t/joCMVyIgpXGm
Currently the remote page cannot store state, and relies on retrieving info from the browser to correctly set state.  It's probably worth fixing to not display as enabled or disabled until the browser responds.
Severity: enhancement → minor
Component: Client: Desktop → Web: Health Report
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1209549
You need to log in before you can comment on or make changes to this bug.