Switch to Grunt for all Linting

RESOLVED FIXED

Status

Webmaker
Popcorn Maker
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mjschranz, Assigned: mjschranz)

Tracking

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Silly me. We've wanted to do this for a bit of time now and we are trying to unify the tech we use across all of our applications.

We use LESS already so that's taken care of, but we don't have Grunt implemented in any form in this application yet.
(Assignee)

Comment 2

5 years ago
One additional thing we need to do here is write a Grunt plugin for https://github.com/mozilla/html5-lint which we use for our HTML linting. Options exist for linting js and LESS.
Assignee: schranz.m → ali
(Assignee)

Comment 3

5 years ago
Apparently :humph already took a stab at getting this sort of grunt plugin working.

Ali, I would take this code and make it a module that any repo can include so we can use this cross project. See https://github.com/mozilla/webmaker.org/pull/14.
Duplicate of this bug: 870813
I have :humph codes published to https://npmjs.org/package/grunt-lint5 and not sure if we need to have this transfer first or?
Flags: needinfo?(pomax)
do this concurrently? "all linting" I imagine means CSS, HTML and JS linting. You could block this issue on those three subtasks (some of which we obviously already do)
Flags: needinfo?(pomax)
Assignee: ali → nobody
(Assignee)

Updated

4 years ago
Assignee: nobody → schranz.m
(Assignee)

Updated

4 years ago
Blocks: 936838
(Assignee)

Comment 7

4 years ago
Created attachment 829806 [details] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/307

Weeeee

For now this removes our linting of HTML files and that's going to be added in a follow up (see current blocks list). Besides, it's only linting the layout files we use that aren't templates.

Apparently our old linting was really bad and didn't catch a whooole lot of stuff. Obviously minor since nothing's gone wrong but still. It was kind of busted. This also allows us to enforce some things like quote style.
Attachment #829806 - Flags: review?(scott)
Comment on attachment 829806 [details] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/307

Fix one comment and land it.
Attachment #829806 - Flags: review?(scott) → review+

Comment 9

4 years ago
Commit pushed to master at https://github.com/mozilla/popcorn.webmaker.org

https://github.com/mozilla/popcorn.webmaker.org/commit/8833fa81067b478752cc441190e794c4cfd0bcb8
Fix Bug 867283 - Add grunt support to Popcorn Maker. Fix a whole crap tonne of hidden lint errors and double quotes vs single quotes

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.