If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find dialog leaves highlighted selections on the screen

RESOLVED FIXED in mozilla1.0

Status

SeaMonkey
General
P3
normal
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Chris Meyer, Assigned: Simon Fraser)

Tracking

Trunk
mozilla1.0
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: OSX, URL)

(Reporter)

Description

17 years ago
Using Fizzilla 2001061314 on Mac OS X 10.0.3

*** TO REPRODUCE
- Bring up the URL above
- Find, enter "NEW" and make it case sensitive
- Keep clicking Find button until the current selection is at the very bottom of
the screen.
- Click it again

*** ACTUAL RESULTS
- Now TWO "NEW"s are highlighted (the correct one and the last one).
- Using the scrollbar its easy to get the incorrectly highlighted one half-erased

*** EXPECTED RESULTS
Only ONE should be highlighted

This has happened for as long as I can remember...

Comment 1

17 years ago
-->sfraser
Assignee: asa → sfraser

Updated

17 years ago
Whiteboard: OSX
(Assignee)

Comment 2

17 years ago
Yeah, the scrolling-with-selection code was #if !TARGET_CARBON, because I was
being lazy.
Severity: minor → normal
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
Can't reproduce this problem under the latest carbon build (2001-08-06-13) with
Mac OS 10.0.4. Anyone still see the problem ?
(Assignee)

Comment 4

16 years ago
I'd be surprised if this was fixed. What happens if you do lots of Find Again on 
a long file with many matches? Does it correctly redraw the selection if it 
scrolls to find the next match?

Comment 5

16 years ago
Can we get this for 0.9.5?
Keywords: nsenterprise+

Comment 6

16 years ago
nsenterprise-; not a stopper
Keywords: nsenterprise+ → nsenterprise-

Comment 7

16 years ago
Methinks sfraser's fix for general window drawing problems (bug #?) fixed this
as I can no longer repro it - marking as FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.