Closed Bug 867372 Opened 7 years ago Closed 7 years ago

Mach gtest doesn't work with default test filter on windows

Categories

(Firefox Build System :: Mach Core, enhancement)

x86
macOS
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla23

People

(Reporter: BenWa, Assigned: BenWa)

Details

Attachments

(2 files)

Attached patch patchSplinter Review
No description provided.
Attachment #743839 - Flags: review?(gps)
How is this failing exactly?
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
*sigh*. It's a Python < 2.7.3 bug where it croaks on unicode passed into environment dicts passed to subprocess.POpen(). We've seen this bug over and over again. We should just change mozprocess or _run_make() to .encode('utf-8') unicode types to str.

Do you mind if I steal this?
That's fine. We already use the b"" syntax for other env variables (in fact you told me to use it in the previous gtest review). Shouldn't we land this patch to be consistent and fix the issue?
Comment on attachment 743839 [details] [diff] [review]
patch

Review of attachment 743839 [details] [diff] [review]:
-----------------------------------------------------------------

Continuing to hack around it is fine by me. I hate this bug so much.
Attachment #743839 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/1d82018a9772
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.