Closed Bug 867487 Opened 7 years ago Closed 7 years ago

"ASSERTION: Sheet thinks it's not complete while we think it is"

Categories

(Core :: CSS Parsing and Computation, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla24
Tracking Status
firefox22 --- unaffected
firefox23 + fixed
firefox24 + fixed

People

(Reporter: jruderman, Assigned: bzbarsky)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(3 files)

Attached file testcase
> ###!!! ASSERTION: Sheet thinks it's not complete while we think it is: 'sheet->IsComplete()', file layout/style/Loader.cpp, line 1101
> ###!!! ASSERTION: Sheet thinks it's not complete while we think it is: 'sheet->IsComplete() || aSheetState != eSheetComplete', file layout/style/Loader.cpp, line 1159

I'm guessing this is a regression from bug 799816.
Attached file stack (gdb)
Indeed.  The problem is that when we forgo using a cached sheet because it's modified we don't reset the fromCompleteSheets boolean.  Patch coming up, with more assertions to catch this earlier.
Assignee: nobody → bzbarsky
Whiteboard: [need review]
Comment on attachment 744153 [details] [diff] [review]
Make sure we don't think we're cloning a complete sheet when we're actually cloning a loading one because the complete sheet was dirty.

Let's try Cameron here.
Attachment #744153 - Flags: review?(dbaron) → review?(cam)
Attachment #744153 - Flags: review?(cam) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/d6e02547f740
Flags: in-testsuite+
Whiteboard: [need review]
Target Milestone: --- → mozilla24
Comment on attachment 744153 [details] [diff] [review]
Make sure we don't think we're cloning a complete sheet when we're actually cloning a loading one because the complete sheet was dirty.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 799816
User impact if declined: Possible weirdness with CSS rendering on pages that
   mutate their stylesheets.
Testing completed (on m-c, etc.): Passes tests.
Risk to taking this patch (and alternatives if risky): Very low risk, in my
   opinion.
String or IDL/UUID changes made by this patch:  None
Attachment #744153 - Flags: approval-mozilla-aurora?
Attachment #744153 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/d6e02547f740
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.