Font with @font-face intermittently not rendering

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: niels, Unassigned)

Tracking

20 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 744053 [details]
Screen Shots showing page with bug and correct version

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31

Steps to reproduce:

View for example http://www.zapp.nl/bios/1132-de-kinderen-van-mijn-zus or http://www.zapp.nl/bios/zappbios-film-lover-of-loser 


Actual results:

Fonts are regularly, but not always, not displayed. You can select the text (it is in the right place), but it is not shown.



Expected results:

The text should be rendered. 
This bug is very difficult to trigger (eg you have to load pages for 50 times before it occurs) with either firebug or developertools open (showing that loading the fonts was aborted, but this is not entirely consistent and possibly a red herring...), otherwise it happens about 50% of the times. Reloading the page (always) fixes the problem.
(Reporter)

Updated

5 years ago
Severity: normal → minor
Hardware: x86 → x86_64
(Reporter)

Updated

5 years ago
OS: Mac OS X → All
Component: Layout: View Rendering → Layout: Text
(Reporter)

Comment 1

5 years ago
This does not occur in the FF 21 branch. Please close.

Comment 2

5 years ago
I'm seeing something very similar at the site: http://rpg.stackexchange.com/

The site uses a web font, Lusitana Regular, and this isn't rendering for me in the last several nightly builds, even in safe mode.  It isn't intermittent, but completely reproducible.

I'm using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:25.0) Gecko/20130723 Firefox/25.0
(In reply to Tim Martin from comment #2)
> I'm seeing something very similar at the site: http://rpg.stackexchange.com/
> 
> The site uses a web font, Lusitana Regular, and this isn't rendering for me
> in the last several nightly builds, even in safe mode.  It isn't
> intermittent, but completely reproducible.
> 
> I'm using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:25.0)
> Gecko/20130723 Firefox/25.0

That sounds like bug 896592, which should be fixed in today's Nightly since bug 879963 was backed out.

The original (intermittent) issue here must have been something different, but given comment 1, I'm closing this report as WorksForMe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.