Ask Confirmation before Loading Flash Plugin

RESOLVED DUPLICATE of bug 549697

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 549697
5 years ago
5 years ago

People

(Reporter: Lex, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Hi,

Firefox works pretty well. It supports many open tabs, many bookmarks, it is really stable. Except for one thing: Flash videos.

I have experienced many, many crashes due to web pages with Flash videos.


Actual results:

Every crash resulted in a new sent report.
So, I am not here to ask for a resolution about this. It also happened with previous versions of Firefox and previous versions of Flash Player.

If you want a description of what happens, you can read https://bugzilla.mozilla.org/show_bug.cgi?id=511555 (except I am runnning on Windows 7).
I load a page with a Flash video and Firefox crashes. And when I restart and that the failing page gets reloaded, Firefox crashes again. Again and again. So, I have to close the tab before it is reloaded.

Disabling the Flash plugin solves the problem.
But the fact is this problem does not occur on all the websites with Flash videos. So, all or nothing is not acceptable.


Expected results:

This ticket is not a bug report.
It is a feature request.

I think there should be some options to define on which websites the Flash plugin can be loaded. Websites that are not white-listed would not be allowed to load this plugin. Visiting a website that is not in any list would show a dialog that would ask whether this website is allowed to load Flash.

As an example, Youtube is one crashing website on my machine.
But Wat TV and Dailymotion are not. What I would like to do, is to configure somewhere in the options, that Flash is disabled for Youtube but allowed on Dailymotion.

Obviously, for a default installation, all the famous flash web sites would be allowed. But people could change this configuration.

Given the history of problems with Flash, no developer can guarantee Firefox will not crash anymore due to this plugin. So, adding some kind of protection, that can be configured by the user, seems reasonable and safe to me. This would improve user confort. Flash crashes are annoying, to say the less. In particular when you have downloads in progress and/or many open tabs.

Comment 1

5 years ago
There is already an ask feature in firefox[1], toggle about:config?plugins.click_to_play to true.

There is also currently ongoing development to make this feature more configurable and on by default[2] (linked in bug 738698).

Marking this as a dup of bug 549697 is it is where click to play was first implemented.

[1] https://blog.mozilla.org/security/2013/01/29/putting-users-in-control-of-plugins/
[2] https://blog.mozilla.org/security/2012/10/11/click-to-play-plugins-blocklist-style/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549697

Comment 2

5 years ago
opps sorry the url is about:config?filter=plugins.click_to_play
(Reporter)

Comment 3

5 years ago
Indeed, I had missed these changes.
Thanks!
You need to log in before you can comment on or make changes to this bug.