Replace diagonal-striped gradient with image because of awful Firefox perf

RESOLVED FIXED in 2013-05-02

Status

Marketplace
Consumer Pages
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cvan, Assigned: scolville)

Tracking

2013-05-02
Points:
---

Details

(Whiteboard: [fireplace] p=1, URL)

(Reporter)

Description

5 years ago
For the diagonal-line pattern in the new Fireplace designs we're using a linear-gradient + background-size.

Firefox chokes on the background-size on a repeating image or gradient, causing noticeable lag when scrolling. WebKit handles this like a champ. Unfortunately, in Firefox this is a legitimate bug (see bug 732150 and bug 846315), wherein the browser recalculates the background-size on every single redraw (i.e., scroll).

So as a workaround let's change our `diagonal-lines` mixin to use a repeating image with no background-size. (I hope retina doesn't look like shit.)
Assignee: nobody → scolville
Status: NEW → ASSIGNED
Target Milestone: --- → 2013-05-02
Duplicate of this bug: 867535
(Reporter)

Updated

5 years ago
Priority: -- → P2
(Reporter)

Comment 2

5 years ago
https://github.com/mozilla/fireplace/commit/5f45a22 

This looks gorgeous. Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.