{compat} Adjacent floating images anomalously spaced on the vertical

VERIFIED INVALID

Status

()

P3
minor
VERIFIED INVALID
20 years ago
20 years ago

People

(Reporter: Crysgem, Assigned: rickg)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

20 years ago
Apprunner Build ID: 1999061908

Comment 1

20 years ago
Created attachment 485 [details]
Note the spacing of each pair of article images

Comment 2

20 years ago
**Alerting 3jrgm@qlink.queensu.ca and py8ieh=bugzilla@bath.ac.uk**
Ye two, who have sat in the tumultuous lee of many similar-seeming bugs, may
quickly assess this report's validity.

Comment 3

20 years ago
Well, here's a test case. Nav4.x and 5.0 have different views of dealing with
the flow into a fixed width block or table (and I don't know which is correct
 -- must go read a bit  ;). Perhaps this is a dup -- py8ieh?

Comment 4

20 years ago
Created attachment 487 [details]
testcase; flowing a second image into a fixed width block or table

Comment 5

20 years ago
*** Bug 8544 has been marked as a duplicate of this bug. ***

Comment 6

20 years ago
Created attachment 531 [details]
testcase; based on bug 8544 -- a variation of the previous attachment to bug 8676

Comment 7

20 years ago
The most recent attachment includes comments explaining the tests (modulo
bonehead proofreading failures). In this test, the behaviour is the same for
tables, but notably 'odd' for the fixed-width divs.
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID
Summary: Adjacent floating images anomalously spaced on the vertical → {compat} Adjacent floating images anomalously spaced on the vertical
All behaviour in all test cases in this bug is per the CSS specs.

 1. Images are equivalent to text in these cases (display:inline), so, like
    text, they should flow to the next line if the container is not wide enough
    to hold them.
 2. A floated image should not affect the parent's borders, so the border in
    the third test case is correct.
 3. If you set the border, padding and margins of the tables to 0, you get the
    same behaviour in cells as in DIVs. In some of the tests, the cell width
    is less than the DIV width, so a direct comparison is incorrect.

Marking bug INVALID.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 9

20 years ago
Agreed. Marking as verified invalid.
You need to log in before you can comment on or make changes to this bug.