mouse wheel accidentally changes font size

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: mike381a, Unassigned)

Tracking

20 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

I move the mouse wheel.


Actual results:

The browser font size often changes by mistake.


Expected results:

The font size should stay the same.

My mousewheel button sends the meta modifier when depressed.  I could be wrong, but it seems that meta + mousewheel seems to have been recently changed to change the font size (in addition to control).

I don't see why this was changed, when control + mousewheel works fine.

I have changed the preference mousewheel.with_meta.action to 0 to fix it, but maybe there could be a visible setting somewhere?
(Reporter)

Comment 1

6 years ago
Oh, I want to point out that I realize I must be accidentally depressing the mouse button a bit when using the scroll wheel, but only with a recent firefox has this issue been encountered.  And encountered all the time.

also, I found these pages:

http://rachelbythebay.com/w/2013/04/05/zoom/

http://night-ray.blogspot.com/2008/01/firefox-scroll-wheel-font-size-changer.html
Actually mousewheel.with_meta.action set to 3 causes zoom with meta button
and mousewheel.with_meta.action to 0 to disable it; This is a Firefox feature.

You can read https://support.mozilla.org/it/questions/955305 to view all the value for 
mousewheel.with_meta.action and change them according to your needs.

Do you have problem with zoom setting mousewheel.with_meta.action to 0?
Flags: needinfo?(mike381)
(Reporter)

Comment 3

6 years ago
I set it to zero a few days ago and the problem was resolved (for me).

My actual question is:  why was meta added for zoom in addition to control?

A lot of people have meta-click mapped to the middle mouse button to select
individual items in a list, and I'm sure they're starting to encounter this
problem, maybe not realizing what is happening.

Thanks
Flags: needinfo?(mike381)
(In reply to Mike Polo from comment #3)
> I set it to zero a few days ago and the problem was resolved (for me).

Thanks for reporting. Since you haven't problems I'll close this.

> My actual question is:  why was meta added for zoom in addition to control?

Control + wheel is reserved by Mac OS; you can read here https://bugzilla.mozilla.org/show_bug.cgi?id=814303 and have an idea of the discussions that carried on this choice.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.