Buttons in b2g browser's slow script dialog don't work

RESOLVED DUPLICATE of bug 830010

Status

Firefox OS
Gaia::Browser
RESOLVED DUPLICATE of bug 830010
5 years ago
5 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Assigned: benfrancis)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Reporter)

Description

5 years ago
I just got the slow-script dialog.  When I click on either one of the buttons (continue / stop script), logcat says

E/GeckoConsole(  144): [JavaScript Error: "TypeError: evt is undefined" {file: "app://browser.gaiamobile.org/js/modal_dialog.js" line: 178}]

The only way out is to close the browser.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
(Reporter)

Updated

5 years ago
Summary: Buttons in slow script dialog don't work → Buttons in b2g browser's slow script dialog don't work

Updated

5 years ago
blocking-b2g: tef? → tef+
(Assignee)

Comment 1

5 years ago
Investigating.
Assignee: nobody → bfrancis
(Assignee)

Comment 2

5 years ago
I created a test case at http://people.mozilla.org/~bfrancis/slow.html which should trigger the slow script dialog.

I can't reproduce the bug on 1.0.1 on inari, 1.1 on leo or mozilla-central on unagi using today's nightly builds. Both buttons behave as expected.

Justin, do you have more precise steps to reproduce?

Flagging qawanted to try to find STR but otherwise I'd suggest reconsidering tef+ if it's not consistently reproduceable.
Keywords: qawanted
This is a duplicate of bug 830010
(Reporter)

Comment 4

5 years ago
Your testcase works fine for me, Ben.

I'm sorry I didn't note the webpage I was on, or how I got it to trigger the slow-script dialog.  I think it involved Gecko hackery, though.

But whatever causes bug 830010 seems like a good candidate for this bug too...
(Assignee)

Comment 5

5 years ago
Yes this bug looks like a dupe of bug 830010

The line of code at which the exception is thrown is https://github.com/mozilla-b2g/gaia/blob/master/apps/browser/js/modal_dialog.js#L178

The browser keeps track of mozbrowsershowmodalprompt events in an array keyed by origin. The event is cleared from the array when the user selects the confirm or cancel button (continue or stop), if the tab is closed or the tab crashes. The exception indicates that at the point at which the user is touching the confirm button an event does not exist for that origin in the array.

I can't figure out how to get the browser in this state.
(Reporter)

Comment 6

5 years ago
What if the dialog is raised by a background tab, and then that tab crashes?
Let's dupe it then.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 830010
You need to log in before you can comment on or make changes to this bug.