The default bug view has changed. See this FAQ.

Make users start over if the abort purchase during PIN setup

VERIFIED FIXED in 2013-05-23

Status

Marketplace
Payments/Refunds
P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Assigned: wraithan)

Tracking

2013-05-23
All
Gonk (Firefox OS)
Points:
---

Details

(Whiteboard: p=1)

(Reporter)

Description

4 years ago
steps to reproduce:
1. Start the purchase flow for a paid app on marketplace-dev
2. Log in as a new user via Persona
3. Create PIN and click continue
4. In the confirm screen, close the screen by clicking "x"
5. Start the purchase flow again


expected behavior:
User is back on the Create PIN

observed behavior:
User is on the Confirm PIN screen. If a user returns after a month, we cannot expect the user to remember what they set as their PIN.

Let us not save the PIN until the user has confirmed it.
(Assignee)

Updated

4 years ago
Priority: -- → P3
Whiteboard: p= → p=1
https://github.com/mozilla/webpay/commit/4c4e037830053f3677ec1c2291194d5e85e1c970

We save the PIN because we have to, but this will detect if they are coming back into the flow (from mkt) and remove their pin if they have a pin but haven't verified it.
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-05-02
(Reporter)

Comment 2

4 years ago
I can still reproduce this on -dev. Same steps as comment 0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Component: Consumer Pages → Payments/Refunds
https://github.com/mozilla/webpay/commit/777a2e612e5dc1def856bd187be71850b9722e94

Fixed as part of another bug fix.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: 2013-05-02 → 2013-05-23
(Reporter)

Comment 4

4 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.