Update to freetype 2.5.0.1

RESOLVED FIXED in mozilla25

Status

()

defect
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: jrmuizel, Assigned: mwu)

Tracking

unspecified
mozilla25
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

This isn't out yet, but will include Adobe's new cff engine:
http://google-opensource.blogspot.ca/2013/05/got-cff.html
I have 2.4.11 passing try, but haven't pushed it.  Good thing, too, waiting for 2.4.12 seems like a good thing.
Posted file OTF fonts
These are pre v.1.0 feura fonts, but have the correct hinting so should be a good comparison.
Posted image Moz Light #1
Posted image Moz Light #2
Posted image cropped Moz Light #1
Posted image cropped Moz Light #2
Posted image cropped Moz Light #3
Posted image cropped Moz Light #4
I've attached files with Freetype and Adobe engines with hinting enabled and disabled. Which do you like the best?
It looks like the gamma correction went wrong with these images. So ignore them.
For a more complete comparison, could we have samples that include all three weights, not just the Light face?
(In reply to Jonathan Kew (:jfkthame) from comment #12)
> For a more complete comparison, could we have samples that include all three
> weights, not just the Light face?

I'm not going to get a chance to do that right now.
Patryk, it's probably better if you just visit me and I can show you lots of samples.
Duplicate of this bug: 870637
Using the Adobe CFF renderer is especially important in Japan where CFF rendering generally gives better results due to the way hinting is done (in the rasterizer rather than manual hinting data in the font for TTF fonts).  Allowing the OS to use a well-made CFF Japanese font would be a huge win for Japanese users.  Among carriers in Japan shipping Android it's fairly standard to license a decent set of Japanese fonts for default use, in addition to the standard Android fonts.
(In reply to Michael Wu [:mwu] from comment #17)
> 2.5.0.1 - https://tbpl.mozilla.org/?tree=Try&rev=7e1846623b5f

That didn't work out. Disabled png support - https://tbpl.mozilla.org/?tree=Try&rev=e9955be04a69
Looks ok on try. I disabled the use of libpng, whose use seems to be limited to supporting color emoji. This patch just contains the changes in gecko code. The rest of the files are just dropped into place from the release tarball.
Assignee: nobody → mwu
Attachment #769321 - Flags: review?(jfkthame)
Disabling freetype's use of libpng seems fine for now, though we may want to reconsider that at some point (e.g. if Android devices start shipping a color emoji font based on that approach). But that can be addressed in a followup if/when it becomes relevant.

What about the effect of the new rasterizer? Are we happy with the resulting text rendering in Fennec, or do we need to be passing any new options to freetype in order to choose our preferred rendering? Patryk, have you had a chance to compare the results, across a range of font sizes and weights?
Flags: needinfo?(padamczyk)
Summary: Update to freetype 2.4.12 → Update to freetype 2.5.0.1
Here's the whole thing if people want to try building with it.
On Fennec 25.01a it looks good. I am in Taipei this week, but I will sync with Jeff next week when I am back in Toronto.
Flags: needinfo?(padamczyk)
Comment on attachment 769321 [details] [diff] [review]
Update to freetype 2.5.0.1

Review of attachment 769321 [details] [diff] [review]:
-----------------------------------------------------------------

r=me; let's get this into the tree, as we clearly want to stay up to date.

If it turns out there are rasterization options we want to tweak in any way to optimize the rendering for our target use-cases, we can always do that in a followup bug.
Attachment #769321 - Flags: review?(jfkthame) → review+
https://hg.mozilla.org/mozilla-central/rev/9426f36c2b77
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Bug 966795 has been opened for updating to freetype 2.5.2.
You need to log in before you can comment on or make changes to this bug.