Implement hooks in the build system to specify api keys for Google

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jlal, Assigned: kgrandon)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

(Whiteboard: [qa-])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
We must allow partner provided credentials though the build system and also provide some credentials for mozilla only (non production) builds.
(Reporter)

Updated

6 years ago
blocking-b2g: --- → tef?
blocking-b2g: tef? → tef+
Are you planning on doing this work, James?
(Assignee)

Comment 2

6 years ago
Kevin vs. Build System.
Assignee: nobody → kgrandon
(Assignee)

Comment 3

6 years ago
Created attachment 746187 [details]
Github pull request pointer

Still have some work/clean up to do on this one. Any initial feedback?
Attachment #746187 - Flags: feedback?(jlal)
(Reporter)

Comment 4

6 years ago
Comment on attachment 746187 [details]
Github pull request pointer

I guess my general request might be to expose a set of functions that add providers to this file and we can add some sanity checks there... That is assuming we expect third-parties to modify this file (which I expect we do?).

IMO- if I where the consumer of these customizations I would want some way to specify a folder/file to load that would either override these settings or utilize the methods exposed within.

For v1.0.1 ++ in the future we might want to do fancier things... The point on providers is correct as we don't want to turn on some features (like ActiveSync) unless our partners have the correct licensing agreements (which they may or may not per release)
Attachment #746187 - Flags: feedback?(jlal) → feedback+
(Assignee)

Comment 5

6 years ago
Hi Chris, Yuren,

Adding you to this bug in case you know of any special processes/documentation we need to update for this. Essentially we are creating a new customizable calendar config for our partners which works the same way as the existing customizable data in build/applications-data.js. Partners will be required to create this file before shipping. They will also need to sign up for a Google oauth account so they can use their own Google oauth credentials. 

The default location of the file will be: distribution/calendar.json.
This will create: apps/calendar/js/presets.js.

Do we have some process/documentation that defines how partners create the distribution folder?
Flags: needinfo?(yurenju.mozilla)
Flags: needinfo?(clee)
we have a customization wiki page here:
https://wiki.mozilla.org/B2G/MarketCustomizations
Flags: needinfo?(yurenju.mozilla)
(Assignee)

Comment 7

6 years ago
Thanks for the information Yuren. Going to ask for the official review, and I will be updating that wiki page once this lands. Thanks!
(Assignee)

Updated

6 years ago
Attachment #746187 - Flags: review?(jlal)
(Reporter)

Comment 8

6 years ago
Comment on attachment 746187 [details]
Github pull request pointer

Conditional r+ please exclude presets.js from the linter (can be done from the makefile). (You can see it exploding on travis).
Attachment #746187 - Flags: review?(jlal) → review+
(Assignee)

Comment 9

6 years ago
Created attachment 747032 [details]
Gaia Distribution Sample Pull Request

Hi Yuren - Here is a pull request which adds a sample calendar.json to your distribution sample repo.
Attachment #747032 - Flags: review?(yurenju.mozilla)
(Reporter)

Comment 10

6 years ago
in master https://github.com/mozilla-b2g/gai  a/commit/0fc065f184e5622a24131956e5b935ebad6bfb2f
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: jsmith
I was not able to uplift this bug to v1-train and v1.0.1.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train and v1.0.1, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 0fc065f184e5622a24131956e5b935ebad6bfb2f
  <RESOLVE MERGE CONFLICTS>
  git commit
  git checkout v1.0.1
  git cherry-pick -x $(git log -n1 v1-train --pretty=%H)
Comment on attachment 747032 [details]
Gaia Distribution Sample Pull Request

r=yurenju and merged, thank you!

https://github.com/yurenju/gaia-distribution-sample/commit/9010d0d170b704ad3426a7206d7c362230a34ae7
Attachment #747032 - Flags: review?(yurenju.mozilla) → review+
Keywords: verifyme
Whiteboard: [qa-]
(In reply to Yuren Ju [:yurenju] from comment #13)
> what is qa-?

qa- in the context of a resolved fixed bug means the development changes made here are not worth verifying from an end-user perspective.

I marked this because the changes here appear to be build system changes, which are not really areas end-to-end QA looks at. We'll continue regression testing on areas that will likely touch on changes in this area, but we won't directly target a verification on this bug specifically.
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
James, can you look into the merge conflicts here?
Flags: needinfo?(jlal)
(Assignee)

Comment 17

6 years ago
Sorry, this is not ready to be uplifted until we uplift the entire feature.
Flags: needinfo?(jlal)
Whiteboard: [qa-] → [qa-][NO_UPLIFT]
Whiteboard: [qa-][NO_UPLIFT] → [qa-]
Jason, did you mean to remove NO_UPLIFT?
Flags: needinfo?(jsmith)
(In reply to John Ford [:jhford] -- If you expect a reply from me, use needsinfo? instead of CC from comment #18)
> Jason, did you mean to remove NO_UPLIFT?

Yes. We've completed a 1.01 uplift now, so we should uplift all caldav related to bugs to associated branches.
Flags: needinfo?(jsmith)
(Assignee)

Comment 20

6 years ago
Landed in v1-train: https://github.com/mozilla-b2g/gaia/commit/3e15bc5f1b96434331323dfbd5a909c796c3c447
Landed in v1.0.1: https://github.com/mozilla-b2g/gaia/commit/1b97511ab91c062b0480ca37ba1496ad4d56efa1
status-b2g18: affected → fixed
status-b2g18-v1.0.1: affected → fixed
Blocks: 873785
Blocks: 873786
(Assignee)

Updated

5 years ago
Flags: needinfo?(clee)
You need to log in before you can comment on or make changes to this bug.