Transition from task-manager to app is incorrect

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: cwiiis, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g18 affected)

Details

(Reporter)

Description

5 years ago
When you long-press home, the current app shrinks into the task manager, which feels correct. However, when you choose an app, the home-screen is shown first, then the app appears from the middle of that. This is especially noticeable if you long-press home, then pick the app you were just in.

Verified as an issue in v1-train, can't recall exactly what happens in v1.0.1 but I'm going to assume it's not priority to fix.
(Reporter)

Comment 1

5 years ago
This is fixed in master, and assuming it's low-risk, would make a really nice addition to v1.1.0 (given bug 859183, it's likely users will see the app switcher a lot). Trying to nail down the commit that fixed it.
(Reporter)

Comment 2

5 years ago
Ends up this is a dupe - great :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859259
(Reporter)

Comment 3

5 years ago
I got this wrong, I must've accidentally built master gaia while testing - this is fixed in master, but I've yet to identify exactly which commit fixes it - will dupe this bug accordingly once I have.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

5 years ago
Seems this is a combination of two bugs, that when cherry-picked onto v1-trains, fix the issue. Bug 804270 is due to be uplifted, but it looks like bug 847241 isn't... Will comment on that bug.
Depends on: 804270, 847241

Updated

4 years ago
Component: Gaia::System → Gaia::System::Window Mgmt
Lots of changes in bug 1061324, closing as WFM
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.