Only available buy apps with credit card payment

RESOLVED FIXED in 2013-08-01

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: eder, Assigned: Tom)

Tracking

2013-08-01
x86
Windows 7
Points:
---
Bug Flags:
affects-durango +

Details

Attachments

(5 attachments)

(Reporter)

Description

5 years ago
Created attachment 744720 [details]
Only available buy apps with credit card payment

steps to reproduce:

1. Open the MarketPlace
2. Find the Paid App 
3. Select any paid app,Example: TestApp (test31)/ Persona login page is opened
4. Enter a new email address to Persona "intertek1" pass: "password"
5. Enter PIN "1234"
6. the MP, only be available on credit card payment




expected behavior:

when is select the payment application must show the two payment options, Mobile_Bill_Paid and CCard_Paid


observed behavior:

Can not display the two payment options only one
Group: client-services-security
Was this on wi-fi or mobile network?
Severity: critical → normal

Updated

5 years ago
Flags: needinfo?(eder.mozbugs)
Priority: -- → P2
(Reporter)

Comment 2

5 years ago
is with Mobile Network
Flags: needinfo?(eder.mozbugs)
Assignee: nobody → wraithan
Assignee: wraithan → nobody
Assignee: nobody → kumar.mcmillan
Created attachment 760570 [details]
http-log.txt

I can reproduce this on stage. Here is an HTTP log.
Keir, any ideas why the purchase of this app is bypassing mobile billing and going straight to credit card?

The entry point: mozilla.bango.net/mozpayments/?bcid=16536850

The price points: billing config ID: 16536850; prices: [{'currency': 'USD', 'amount': '0.99'}, {'currency': 'PLN', 'amount': '3.84'}, {'currency': 'GBP', 'amount': '0.75'}, {'currency': 'CAD', 'amount': '0.99'}, {'currency': 'COP', 'amount': '2060.00'}, {'currency': 'EUR', 'amount': '0.89'}]

I don't see anything wrong with the prices.
Assignee: kumar.mcmillan → keir
oops, I was only able to reproduce it because I'm on T-Mobile (an unsupported carrier).

Eder, which carrier/region were you in? Perhaps yours was unsupported too. Eder, if it's still reproducible can you attach an ezboot HTTP log so I can see your carrier details?
Assignee: keir → nobody
Flags: needinfo?(eder.mozbugs)

Updated

5 years ago
Flags: affects-durango+

Comment 6

5 years ago
Issue no longer occurs
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Flags: needinfo?(eder.mozbugs)

Updated

5 years ago
Status: RESOLVED → VERIFIED
Created attachment 778421 [details]
CC prompt instead of carrier billing.

This issue still occurs in prod on buri device with polish locale and Poland region, screenshot attached. I'm trying to buy 3.99zł app on 3G and can see only CC prompt. Please reopen.
Attachment #778421 - Flags: feedback+

Comment 8

5 years ago
Will re-open and assign to Bango, but in the future please file a new bug.
Assignee: nobody → tom
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

5 years ago
What price point is this? I am seeing 3.99 and 3.84... if it is 3.99 then it will take you to the CB option if anything else it will take you to CC only. For example 3.84 is not a price point therefore goes to CC.

Which region is this?
Sorry for the screenshot quality. This is 3.99 zł and it should take me to CB. This is the target device, region Poland, polish locale.
Still there are two apps which have proper pricepoints 3.99zł and CC billing only:
IQ FitFun and Pixeltest.
(Assignee)

Comment 12

5 years ago
Fixed.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Created attachment 781619 [details]
error.jpg

Still not fixed.
First error after trying to purchase IQ FitFun.
Created attachment 781622 [details]
error2.jpg

Second try to purchase IQ FitFun. This screen is visible everytime I try to purchase it. There should be CB confirmation screen instead.

It says: Error. An error occured during request processing. Cancel.
(Assignee)

Comment 15

5 years ago
We are getting a number of Connect Errors showing on our system. The actual response is "Could not connect to the operator" hence the screen you are seeing. We are making all calls successfully but when we try to do the billing we can't connect.
Why is this only for this one app? Adding Virendra, as this seems to be on SDP side.
Target Milestone: --- → 2013-08-01

Comment 17

5 years ago
(In reply to Krzysztof Mioduszewski from comment #16)
> Why is this only for this one app? Adding Virendra, as this seems to be on
> SDP side.

If this is still reproducible, please reopen the bug because right now it is marked as resolved-fixed.
See comment 21 in Bug 898302 - looks like this bug is still open since it was reproduced on 7/30/2013.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I can't find any actual evidence that https://bugzilla.mozilla.org/show_bug.cgi?id=898302#c21 is a dupe of this bug so I'm re-closing. 

I did however find some likely explanations: https://bugzilla.mozilla.org/show_bug.cgi?id=898302#c27
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.