avis.com locks up Linux with wild disk activity

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Mike Abbott, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060713

Simply visiting www.avis.com sends Mozilla 0.9 and 0.9.1 running away
on my Red Hat Linux 7.1 system.  The disk is very busy and no other
processes run.  Perhaps it's swapping madly but I can't tell because
nothing else runs.  Setting low resource limits on memoryuse and
cputime don't make it stop after a while -- it runs for as long as
I let it.  Nicing it up doesn't let anything else run.

Reproducible: Always
Steps to Reproduce:
1.sync
2.Fire up mozilla and type in www.avis.com.
3.After half the page paints, watch the disk go wild because that's
all you can do.

Actual Results:  Heavy disk activity.  X freezes.  I don't have a kernel debugger
so I can't break into Linux to see what's up.  Hope you do!

Expected Results:  Allowed me to rent an Avis car on-line. :)

Java and javascript are enabled. Installation is vanilla except for
Flash and Real plugins.

Comment 1

17 years ago
It doesn't do anything wild with the current nightly and RedHat with 2.4.4 kernel.
How big swapspace do you have? You have to have swap >= 2xRAM with 2.4.x kernel.
Otherwise the system can lock up when some app allocates big memory.

(Reporter)

Comment 2

17 years ago
You're right it doesn't happen with nightly build 2001062008.
My swap is 2x memory anyway.  Still Linux 2.4.2.

I read somewhere that 0.9 was on a branch off the main tree.
I'll leave this bug open in case it's a bug only on that
branch.  You get to decide. :)

Thanks for the prompt response!
(Assignee)

Comment 3

17 years ago
Worksforme with 062004 mozilla win32 build on win2K and win98, 062008 mozilla
linux build on RedHat 6.2 and 062008 mozilla mac build on OS 8.5 and 9.1 Please
reopen if you are still seeing this with a current nightly build. Thanks for
your help in testing Mozilla and reporting bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.