Closed Bug 868152 Opened 7 years ago Closed Last year

Intermittent 40929-1.html,430124-1.html,432114-1.html ,436900-2.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed]

Categories

(Core :: Audio/Video: Playback, defect, P5)

ARM
Android
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: crash, intermittent-failure, Whiteboard: [leave open][test disabled on Android])

Crash Data

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=22516509&tree=Mozilla-Inbound

Android Armv6 Tegra 250 mozilla-inbound opt test crashtest on 2013-05-02 13:03:59 PDT for push 9c426bd08d28
slave: tegra-090

REFTEST TEST-START | http://10.250.49.156:30090/tests/content/media/test/crashtests/852838.html | 482 / 2356 (20%)
INFO | automation.py | Application ran for: 0:01:50.915110
INFO | zombiecheck | Reading PID log: /tmp/tmpp2lk9lpidlog
mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-armv6/1367519192/fennec-23.0a1.en-US.android-arm-armv6.crashreporter-symbols.zip
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-inbound-android-armv6/1367519192/fennec-23.0a1.en-US.android-arm-armv6.crashreporter-symbols.zip
PROCESS-CRASH | http://10.250.49.156:30090/tests/content/media/test/crashtests/852838.html | application crashed [@ libc.so + 0xf240]
Crash dump filename: /tmp/tmpBn5AlD/23c55a73-500c-74d6-710041f9-563035f2.dmp
Operating system: Android
                  0.0.0 Linux 2.6.32.9-00002-gd8084dc-dirty #1 SMP PREEMPT Wed Feb 2 11:32:06 PST 2011 armv7l nvidia/harmony/harmony/harmony:2.2/FRF91/20110202.102810:eng/test-keys
CPU: arm
     2 CPUs

Crash reason:  SIGSEGV
Crash address: 0x0

Thread 39 (crashed)
 0  libc.so + 0xf240
     r4 = 0x00000000    r5 = 0x00000000    r6 = 0x00000000    r7 = 0x00000000
     r8 = 0x00000000    r9 = 0x00000000   r10 = 0x00000000    fp = 0x00000000
     sp = 0x5ac27dd0    lr = 0x539e0bb0    pc = 0xafd0f240
    Found by: given as instruction pointer in context
 1  libxul.so!mozilla::BufferedAudioStream::GetUnprocessed(void*, long) [AudioStream.cpp:9c426bd08d28 : 790 + 0x6]
     sp = 0x5ac27df8    pc = 0x539e0bb0
    Found by: stack scanning
 2  libutils.so + 0x1c3f7
     sp = 0x5ac27e10    pc = 0xa811c3f9
    Found by: stack scanning
 3  libxul.so!mozilla::BufferedAudioStream::DataCallback(void*, long) [AudioStream.cpp:9c426bd08d28 : 846 + 0x2]
     sp = 0x5ac27e18    pc = 0x539e0de0
    Found by: stack scanning
 4  libmedia.so + 0x5b386
     sp = 0x5ac27e30    pc = 0xa905b388
    Found by: stack scanning
 5  libxul.so!audiotrack_refill [cubeb_audiotrack.c:9c426bd08d28 : 106 + 0x16]
     sp = 0x5ac27e40    pc = 0x545304e8
    Found by: stack scanning
 6  libxul.so!audiotrack_init [cubeb_audiotrack.c:9c426bd08d28 : 271 + 0x42]
     sp = 0x5ac27e44    pc = 0x545304a4
    Found by: stack scanning
Duplicate of this bug: 868153
https://tbpl.mozilla.org/php/getParsedLog.php?id=22517290&tree=Mozilla-Central
Summary: Intermittent media/test/crashtests/852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed] → Intermittent 40929-1.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed]
Crash Signature: [@ mozilla::BufferedAudioStream::GetUnprocessed(void*, long)]
it seems that commenting out: content/media/test/crashtests/459439-1.html allows me to run to completion locally.
We'll see if skipping 459439-1.html helps.
https://hg.mozilla.org/mozilla-central/rev/cdd14d9b3aae
Whiteboard: [leave open]
(In reply to TinderboxPushlog Robot from comment #42)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=22534652&tree=Mozilla-
> Central
> Android Armv6 Tegra 250 mozilla-central opt test crashtest on 2013-05-02
> 20:09:13
> slave: tegra-358
> 
> PROCESS-CRASH |
> http://10.250.48.33:30358/tests/content/media/test/crashtests/852838.html |
> application crashed [@ libc.so + 0xf240]

What should we skip next, Joel?
Summary: Intermittent 40929-1.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed] → Intermittent 40929-1.html,436900-2.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed]
also if I just comment out: content/media/test/crashtests/466945-1.html, it will run to completion locally.  could it be that we just have too many tests doing autoplay and android cannot keep up with it?
(In reply to comment #67)
> also if I just comment out: content/media/test/crashtests/466945-1.html, it
> will run to completion locally.  could it be that we just have too many tests
> doing autoplay and android cannot keep up with it?

Does it help if you stop the element before the test is unloaded?
I tried using the pause, I am not familiar with how to detect unload and stop the playing.  the pause didn't help, but then again, these tests are all a bit different and I could have done something totally wrong.
https://tbpl.mozilla.org/php/getParsedLog.php?id=22572185&tree=Mozilla-Inbound
Summary: Intermittent 40929-1.html,436900-2.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed] → Intermittent 40929-1.html,430124-1.html,436900-2.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed]
(In reply to Joel Maher (:jmaher) from comment #67)
> also if I just comment out: content/media/test/crashtests/466945-1.html

Whac-A-Mole? My favorite game! https://hg.mozilla.org/integration/mozilla-inbound/rev/c097ee28852a

(My second favorite is Hide-And-Then-Turn-Off-Android-Tests, which comes pretty soon, this is well beyond insanely awful.)
Honestly, just hide it. It clearly doesn't meet the requirements of the visibility policy.
https://tbpl.mozilla.org/php/getParsedLog.php?id=22578203&tree=Mozilla-Inbound
Summary: Intermittent 40929-1.html,430124-1.html,436900-2.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed] → Intermittent 40929-1.html,430124-1.html,432114-1.html ,436900-2.html,852838.html | application crashed [@ libc.so + 0xf240] [mozilla::BufferedAudioStream::GetUnprocessed]
Ten runs each:

armv6 hit this on eight, infra failure on one, green on one

2.2 hit this on seven, just stopped on one, green on two

4.0 was green on ten

Not sure what the right-and-possible thing to do is, since both right things, either run unified C only on 4.0 or make every single audio crashtest test including ones not yet written do a runtime isThisATegra determination and abort if it is, aren't very possible. In the meantime, yeah, I'm hiding the 2.2 C on every trunkish tree.
And not surprisingly, if we skip all of content/media/test/crashtests/, https://tbpl.mozilla.org/?tree=Try&rev=dba6ca3e1939&showall=1, we're pure and green as the driven snow.
yeah, we could disable 2 or 3 tests in there and be just as good.  I would be happy to do some trial and error for a day or so to see if we can really fix this at the test level.  With the crash stack, I would assume the developers could knock this out.
with the one test case commented out for android we are still having a lot of crashes. 

lets just comment out the audio directory until somebody can look at this null pointer.  Fact of the matter is these tests were not running before and they are hidden now (i.e. nobody cares about them).  Now that they are on, we can test fixes on try server and all is good.
as :philor pointed out, disabling this directory does wonders for stability.  These tests have not been running for the last year, they are hidden (i.e. nobody watches them), lets just disable the offenders for now so we can benefit from greater test coverage.
Attachment #746446 - Flags: review?(ehsan)
Comment on attachment 746446 [details] [diff] [review]
get crashtests green for android (1.0)

I'm not the right reviewer for this.
Attachment #746446 - Flags: review?(ehsan) → review?(roc)
Comment on attachment 746446 [details] [diff] [review]
get crashtests green for android (1.0)

I, on the other hand, am the right reviewer for it - heck, I turned them off, quite possibly before they even existed, when I turned off crashtest-1 last year without asking any of the people whose crashtests were being turned off whether they liked it. Land it, so we can get crashtest-2 and crashtest-3 turned off and get our capacity gain instead of the 2/3 capacity decrease we're stuck with now because we have these hidden so we have to leave the old chunks running.
Attachment #746446 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/801c4ba14ee6
Whiteboard: [leave open] → [leave open][test disabled on Android]
Crash Signature: [@ mozilla::BufferedAudioStream::GetUnprocessed(void*, long)] → [@ mozilla::BufferedAudioStream::GetUnprocessed(void*, long)] [@ mozilla::BufferedAudioStream::GetUnprocessed]
Component: Audio/Video → Audio/Video: Playback
Priority: -- → P5
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.