[Email] "Body" search filter broken by change to body representation

VERIFIED FIXED in 1.1 QE2 (6jun)

Status

--
major
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: psingapati)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 verified, b2g18-v1.0.1 affected)

Details

(Whiteboard: MiniWW, leorun3, leorun4, burirun1, URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
1. Title : Email "Body" search filter is broken, always shows empty
2. Precondition : Email account is configured
3. Tester's Action :Go to Email -> Inox ->Search any in Body filter -> It always shows empty.
4. Detailed Symptom (ENG.) : "Body" filter always shows empty.
5. Expected :All search filters should be shown properly.
6.Reproducibility: Y
	1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 8560da0c79b293cb421e33dc9b99f2afc12b6fdf
9.Personal email id:  psingapati@gmail.com
I confirmed this on IRC; the body search logic is still expecting the pair-wise array elements rather than the object.  We 100% need to land proper unit tests with this fix that open a slice.  The standalone mocked up search unit tests are still desirable, especially for the snippet logic tests, but are insufficient.  We can then use these tests in the deletion-from-searhc-view bug we've got.
(Reporter)

Updated

6 years ago
Assignee: nobody → leo.bugzilla.gaia
(Reporter)

Updated

6 years ago
Assignee: leo.bugzilla.gaia → nobody
(Assignee)

Comment 2

6 years ago
Created attachment 754819 [details]
Proposed patch gelam PR

body rep is an object which has type and content.
Assigned Object.type and Object.content to bodyType and bodyRep

Please review
Attachment #754819 - Flags: review?(bugmail)

Updated

6 years ago
Whiteboard: MiniWW
(Reporter)

Comment 3

6 years ago
As discussed during San Diego work week, marking this leo+
blocking-b2g: --- → leo+
Comment on attachment 754819 [details]
Proposed patch gelam PR

Whatever you're doing for the MIME type on the attachments isn't working; maybe just explicitly type in text/html from here on out and make sure to hit the radio button? :)

r=asuth with conditional fix that I've now made for you for expediency.  landing...
Attachment #754819 - Attachment mime type: text/plain → text/html
Attachment #754819 - Flags: review?(bugmail) → review+
landed on gaia-email-libs-and-more/master:
https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/210
https://github.com/mozilla-b2g/gaia-email-libs-and-more/commit/49b176e58defc69f8c1619f73ee4367379c98eee

landed on gaia/master:
https://github.com/mozilla-b2g/gaia/pull/10060
https://github.com/mozilla-b2g/gaia/commit/be269ce7cba62e20fbd5d555260dc657791f51a6
Assignee: nobody → psingapati
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
Resolution: --- → FIXED

Updated

6 years ago
Target Milestone: --- → 1.1 QE2 (6jun)
Uplifted be269ce7cba62e20fbd5d555260dc657791f51a6 to:
v1-train: aa17a23b1b0fe1482ff84cd283d057133ecee7d6
status-b2g18: affected → fixed

Updated

5 years ago
Flags: in-moztrap?

Comment 7

5 years ago
This issue still reproduces on Leo build ID: 20130610070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/8e3f39363c54
Gaia: ce3b99781d182ad550a325206990c249b0dbcf0e
Platform Version: 18.0

This issue continues to reproduce exactly as it described in comment 0. The "Body" filter always shows empty.
Whiteboard: MiniWW → MiniWW, leorun3
Flags: in-moztrap? → in-moztrap+
There's been a change in behaviour relating to body fetching and downloading that makes this issue more complicated, and the moztrap case does not reflect that.

If you do not click on a message to display it for reading, then we only fetch up to 4k of the message.  If this 4k does not get us the entirety of the message, then the message is *not* searchable.  I have filed bug 882840 about this.

In the meantime, the moztrap test case should call for the tester to click on a message to read it, waiting for the message to display.  Once the message is displayed, it should be visible in body search.

Mila, if you can update the moztrap case to express this and then re-run verification under these constraints, that would be appreciated.
Flags: needinfo?(mdavydova)

Comment 9

5 years ago
(In reply to Andrew Sutherland (:asuth) from comment #8)

Hi Andrew.

The issue I am currently seeing:
I perform a body search for a specific word.
I have multiple emails in my inbox with as little as 3-4 words each. 
When I search for a word I am certain is in the bodies of those emails, no results will be found with that criteria.
Flags: needinfo?(mdavydova)
Have you displayed those messages in the message reader prior to trying the body search?  What does an adb logcat show?

Comment 11

5 years ago
Created attachment 762296 [details]
logcat

Comment 12

5 years ago
Yes, the messages were read prior to search.

Also, I've noticed, that sometimes, after an unsuccessful body search, the results for words are not shown under other tubs  as well. Switching between search tubs brings no results.
Example: I have an emails with "hotmail" word in both: address field and email body. When I typed "hotmail" word and searched under "body" tab, the email was not found. When I switched to "From" tab, results page was empty as well. 

Logcat is attached.
The logcat is telling me that it is dying on HTML e-mails because we are trying to access the DOM on the worker.  I've filed bug 882917 which is going to require some pretty thorough unit tests...
Summary: [Email] Email "Body" search filter is broken, always shows empty → [Email] "Body" search filter broken by change to body representation
Still repros on Leo 1.1 commercial RIL.

Build ID: 20130625070217
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1
RIL Version: 01.01.00.019.138
(In reply to ckreinbring from comment #14)
> Still repros on Leo 1.1 commercial RIL.
> 
> Build ID: 20130625070217
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
> Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
> Platform Version: 18.1
> RIL Version: 01.01.00.019.138

Was it a text/plain or text/html message?  Per my comment 13, failure on text/html is expected and is bug 882917.  The moztrap test case should probably be split into two separate tests based on the type of message.
Plain text email.

Updated

5 years ago
Whiteboard: MiniWW, leorun3 → MiniWW, leorun3, leorun4
Verified fixed on Leo 1.1 commercial RIL.

Build ID: 20130715070218
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
Gaia: 55ed5e08a2250ea2d3571fff860c39e66fabed14
Platform Version: 18.1
RIL Version: 01.01.00.019.158
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified

Updated

5 years ago
Depends on: 919003

Comment 18

5 years ago
This issue still repros on both 1.1 and 1.2.  New bug 919003 is filed for this issue.
Whiteboard: MiniWW, leorun3, leorun4 → MiniWW, leorun3, leorun4, burirun1
You need to log in before you can comment on or make changes to this bug.