Caret position lost while editing mail

CLOSED DUPLICATE of bug 67847

Status

MailNews Core
Composition
--
major
CLOSED DUPLICATE of bug 67847
17 years ago
10 years ago

People

(Reporter: Joerg Sievers, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
mozilla0.9.2

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When deleting the end of a paragraph (when editing an e-mail) the cursor
position is lost and gets resetted to the beginning of the e-mail.

Comment 1

17 years ago
Steps to reproduce:

1. Reply to existing mail or news message using the plain text editor.
2. Go somewhere in the middle of the quoted material, select everything down to
the end of the quoted material.
3. Press Delete.

The cursor jumps to the first line of the message editor, instead of below the
remaining quoted material.  It does so regardless of whether there's non-quoted
material below the quoted material or not.  Deleting non-quoted material works
as expected.

Comment 2

17 years ago


*** This bug has been marked as a duplicate of 67847 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Summary: Cursor position lost while editing mail → Caret position lost while editing mail
Target Milestone: --- → mozilla0.9.2
(Reporter)

Comment 3

17 years ago
doubled #67847
Status: RESOLVED → CLOSED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.