If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Rooting hazard in calDateTime

RESOLVED DUPLICATE of bug 918819

Status

Calendar
Internal Components
RESOLVED DUPLICATE of bug 918819
4 years ago
4 years ago

People

(Reporter: jcranmer, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
calDateTime::GetJsDate/SetJsDate are the only major uses of JSAPI in comm-central, and thus susceptible to rooting issues. However, the functions are pretty simple, and the only functions which could GC are JS_NewDateObject*, js::CheckedUnwrap, and JS_AutoCompartment. Of those, the only use we need to keep alive is JSObject *dobj, which crosses the AutoCompartment.

Updated

4 years ago
Component: General → Internal Components
OS: Windows 7 → All
Hardware: x86_64 → All
Version: unspecified → Trunk
Blocks: 898606
No longer blocks: 753203
(Reporter)

Comment 1

4 years ago
As far as I understand it, this was fixed by bug 918819.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918819
Great! I'm glad our handlification efforts both uncovered and solved this without further analysis.
You need to log in before you can comment on or make changes to this bug.